continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: Continuum classloader issues
Date Thu, 21 Dec 2006 14:26:17 GMT
no, continuum use mvn available in your PATH. maven lib under apps/continuum/lib aren't used
for the project build.

Emmanuel

Georg Öttl a écrit :
> Hi Emmanuel
> 
> are you sure continuum use the same maven version and same plugins versions
>> that you use when you run maven directly?
>>
> 
> I guess that continuum uses the maven versions in its lib directory. If the
> version numbers are allright it should be the same version (it says 
> maven-*-
> 2.0.4) as I use without continuum. I tried it on different os'es (winxp
> single, linux dual). The problem was reproducible on both computers.
> 
> [snip]
> dir: goettl@nqweba:~/continuum-1.0.3/apps/continuum/lib
> ...
> maven-artifact-2.0.4.jar
> maven-artifact-manager-2.0.4.jar
> maven-core-2.0.4.jar
> maven-error-diagnostics-2.0.4.jar
> maven-model-2.0.4.jar
> maven-monitor-2.0.4.jar
> maven-plugin-api-2.0.4.jar
> maven-plugin-descriptor-2.0.4.jar
> maven-plugin-parameter-documenter-2.0.4.jar
> maven-plugin-registry-2.0.4.jar
> maven-profile-2.0.4.jar
> maven-project-2.0.4.jar
> maven-reporting-api-2.0.4.jar
> maven-repository-metadata-2.0.4.jar
> maven-scm-api-1.0-beta-3.jar
> maven-scm-manager-plexus-1.0-beta-3.jar
> maven-scm-provider-bazaar-1.0-beta-3.jar
> maven-scm-provider-clearcase-1.0-beta-3.jar
> maven-scm-provider-cvs-commons-1.0-beta-3.jar
> maven-scm-provider-cvsexe-1.0-beta-3.jar
> maven-scm-provider-local-1.0-beta-3.jar
> maven-scm-provider-perforce-1.0-beta-3.jar
> maven-scm-provider-starteam-1.0-beta-3.jar
> maven-scm-provider-svn-commons-1.0-beta-3.jar
> maven-scm-provider-svnexe-1.0-beta-3.jar
> maven-settings-2.0.4.jar
> [snip]
> 


Mime
View raw message