continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: Internal problem with version number?
Date Mon, 20 Nov 2006 09:47:10 GMT
You can't add a multi-module project from a repository because continuum calculate the download
path 
of module from the parent url.

You need to provide a pom.xml file in the url field and you must use an url that respect the

directory structure of your poms. If you have a http interface on your scm, it would be better
to 
use it.

Emmanuel

David Leangen a écrit :
> Thank you for the quick reply!
> 
> Mail sent privately for POM content.
> 
> I'm using version 1.0.3.
> 
> 
> Cheers,
> Dave
> 
> 
> 
> 
> On Mon, 2006-11-20 at 09:59 +0100, Emmanuel Venisse wrote:
>> I've nevever seen this pb.
>>
>> What is your continuum version?
>>
>> Send your poms.
>>
>> Emmanuel
>>
>> David Leangen a écrit :
>>> Is it possible that the version number is somehow not working correctly?
>>>
>>> Continuum keeps try to download URLS like:
>>>
>>> http://www.company.com/repo/com/company/top_module/top_module/0.1.0-SNAPSHOT/top_module-0.1.0-SNAP/module/pom.xml.
>>>
>>> when it should be
>>>
>>> http://www.company.com/repo/com/company/top_module/module/0.1.0-SNAPSHOT/module-0.1.0-SNAPSHOT.pom
>>>
>>>
>>> This obviously finds no file since URL does not make any sense, but I
>>> don't understand why this happens. Do I probably have something wrong in
>>> my pom? Or would this be due to some kind of bug?
>>>
>>>
>>> Thank you!
>>>
>>>
>>>
>>>
>>>
>>>
>>>
> 
> 
> 
> 


Mime
View raw message