continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naess, Ronny" <Ronny.Na...@avinor.no>
Subject SV: Continuum Startup error even though JAVA_HOME is set up
Date Fri, 27 Oct 2006 06:39:54 GMT
We run Continuum on a unix server and have explicit added JAVA_HOME and
added maven and ant into PATH in run.sh.

On a Windows box it should probably be enough just to have JAVA_HOME,
ANT_HOME (if needed) and M2_HOME configured as environment variables.
You must ofcourse have %ANT_HOME%\bin and %M2_HOME%\bin in %PATH%
aswell. Test in shell by typing ant or mvn to verify. I guess you know
this already and that you have this settings configured and that this
might not be your problem?

-Ronny 

-----Opprinnelig melding-----
Fra: datech [mailto:arora_da@hotmail.com] 
Sendt: 26. oktober 2006 22:35
Til: continuum-users@maven.apache.org
Emne: Re: Continuum Startup error even though JAVA_HOME is set up


Does that mean, I will need to modify the run.bat (for Windows NT) to
include Maven Home and Ant Home?
But I don't see it referring to Maven home and Ant Home in the bat file.
I still haven't solved the problem. Please help with more hints.

Thanks



Naess, Ronny wrote:
> 
> I had simulare problems on Solaris.
> I ended up specifying JAVA_HOME and M2_HOME and updating PATH with 
> M2_HOME\bin inside run.sh As I now JAVA_HOME must exist and maven/ant 
> must exist in path when running continuum. For me it was not enough to

> specify them in user environment
> 
> -Ronny
> 
> -----Opprinnelig melding-----
> Fra: datech [mailto:arora_da@hotmail.com]
> Sendt: 25. oktober 2006 02:17
> Til: continuum-users@maven.apache.org
> Emne: Continuum Startup error even though JAVA_HOME is set up
> 
> 
> I did find this problem in forums but the resolution specified didn't 
> work for me. I do have JAVA_HOME set up in my system and also I tried 
> modifying the wrapper.conf to specify the absolute path to my 
> JAVA_HOME instead of it using %JAVA_HOME%, but that didn't work too.
> 
> I am getting  this error while trying to start up Continuum from 
> Win32/run.bat script
> | Critical error: wait for JVM process failed
> Press any key to continue . . .
> 
> 
> Please suggest what else could I change to make it work.
> 
> 
> --
> View this message in context:
> http://www.nabble.com/Continuum-Startup-error-even-though-JAVA_HOME-is
> -s
> et-up-tf2504948.html#a6984052
> Sent from the Continuum - Users mailing list archive at Nabble.com.
> 
> 
> 
> 
> 
> 

--
View this message in context:
http://www.nabble.com/Continuum-Startup-error-even-though-JAVA_HOME-is-s
et-up-tf2504948.html#a7019334
Sent from the Continuum - Users mailing list archive at Nabble.com.


!DSPAM:45411c0b56669724523251!


Mime
View raw message