continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiaqi Guo <>
Subject Customized settings.xml is never loaded
Date Fri, 25 Aug 2006 23:36:05 GMT

To deploy packages to remote repository through scp, I created the
settings.xml under <continuum_install_dir>/bin/linux/conf/ where
username(different from current user of os), privateKey of distribution
server and a non-default localRepository path are defined. From the log file
it seems the settings.xml file is loaded

- Building Maven global-level settings from:

However the mvn deploy goal always fails for authorized connection and jar
files are always downloaded to /.m2/repository (run as root). I've tried to
copy the settings.xml to /.m2, /root/.m2, $M2_HOME/conf/, and even set in launching
command and building definition. The settings.xml never gets actually loaded
even though the log file says so.

If I run mvn command with --settings or
option packages are just deployed as expected.

I'm running continuum-1.0.3 with maven-2.0.4 on redhat-7.2.

Does anyone successfully make continuum load customized settings.xml file?
How did it work? Thanks.

View this message in context:
Sent from the Continuum - Users forum at

View raw message