continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: using continuum from a remote repository build thru maven deploy
Date Tue, 29 Aug 2006 13:47:18 GMT
You need to allow the file protocol in continuum conf( it's explain in faq), then, you restart

continuum.

In "Add Maven project" screen, you can use file://path to your pom in URL field but your project

need to be checkouted on your linux first.

An other solution would be to install a viewcvs on your HP UX and use the http protocol with
the 
viewcvs address in the URL field.

Emmanuel

Rakesh_Malhotra@vwr.com a écrit :
> Hi Emmanuel,
> 
>   I have my CVS repository on a HP UNIX box. My continuum is loaded on a
> Linux box. When I start conitnuum on the linux box and access it thru web
> browser interface how will I abe able to use the file protocol.
> 
> Any ideas?
> Thanks
> 
> 
>                                                                                     
                                                  
>                       Emmanuel Venisse                                              
                                                  
>                       <emmanuel@venisse        To:       continuum-users@maven.apache.org
                                             
>                       .net>                    cc:                               
                                                     
>                                                Subject:  Re: using continuum from a remote
repository build thru maven deploy          
>                       08/29/2006 09:23                                              
                                                  
>                       AM                                                            
                                                  
>                       Please respond to                                             
                                                  
>                       continuum-users                                               
                                                  
>                                                                                     
                                                  
>                                                                                     
                                                  
> 
> 
> 
> 
> It isn't possible to use a remote repository for multi-modules projects.
> 
> If you can't access to you scm with http, you can use the file protocol.
> You need to allow it
> before, check the faq.
> 
> Emmanuel
> 
> 
> Rakesh_Malhotra@vwr.com a écrit :
>> Hi,
>>
>>
>> I am trying to work with continuum and I have a multi module project. The
>> multi module project in continuum requires a URL reference to the parent
>> POM. I was trying to point the http URL to the parent pom.xml created on
>> remote repository using mvn deploy. Problem I am facing is that the mvn
>> deploy does not deploy the artifacts and pom.xml in the same directory
>> structure as is on my c drive.
>>
>>
>> For example my parent project is conversion and it has 2 modules
>> conversion1 and conversion2.
>>
>>
>> In my c drive the directory structure is as follows
>>
>>
>> c:\covnersion (c:\conversion\pom.xml has groupId as "com.mycompany" and
>> artifactId as "conversion" and version number as "SNAPSHOT".)
>>
>>
>> c:\conversion\conversion1 (c:\conversion\conversion1\pom.xml  has
> reference
>> to parent pom and its artifactId is "conversion1" )
>>
>>
>> c:\conversion\conversion2 (c:\conversion\conversion2\pom.xml  has
> reference
>> to parent pom and its artifactId is "conversion2" )
>>
>>
>>  but when I do mvn deploy
>>
>>
>> the remote repository has the following directory structure.
>>
>>
>> com/mycompany/conversion/SNAPSHOT/parentpom.xml
>>
>>
>> com/mycompany/conversion1/SNAPSHOT/conversion1pom.xml
>>
>>
>> com/mycompany/conversion2/SNAPSHOT/conversion2pom.xml
>>
>>
>> So when I point the continuum url to
>>
> http://com.mycompany.mserver/webapps/maven-rep/inhouse/com/mycompany/conversion/SNAPSHOT/parentpom.xml
> 
>> (Embedded image moved to file: pic09514.gif)
>>
>>
>> continuum is unable to locate the module pom's .
>>
>>
>> How do I resolve this? Any ideas would be appreciated.
>>
>>
>> Thanks
>>
>>
>>
>> The information contained in this e-mail message may be privileged,
>> confidential and protected from disclosure. If you are not the intended
>> recipient, any dissemination, distribution or copying is strictly
>> prohibited. If you think that you have received this e-mail message in
>> error please e-mail the sender and delete the message. Thank you.
>>
>>
>>
>>
>>
>>
> 
> 
> 
> 
> 
> 
> 
> 
> 


Mime
View raw message