continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wim Deblauwe" <wim.debla...@gmail.com>
Subject Re: ClearCase SCM and Continuum
Date Tue, 20 Jun 2006 06:30:50 GMT
1) This is the way that ClearCase works, there is nothing I know we can do
about it.

2) I guess the workaround here would be to add the submodules individually.
You can remove the view that was created via cleartool or from the clearcase
home base.

regards,

Wim

2006/6/19, ArneD <public@degenring.de>:
>
>
> Hi,
>
> I am trying to use Maven and Continuum with ClearCase as the SCM provider.
>
> In my pom I have the following entry:
>
> ----
>   <scm>
>     <connection>scm|clearcase|\\svxxxxx\ccviews\myproj.txt</connection>
>   </scm>
> ----
>
> My config spec file myproj.txt looks like this:
>
> ----
> element * CHECKEDOUT
> element * /main/LATEST
> load /TEST/integration/components/MyProj
> ----
>
> The clearcase-settings.xml looks like this:
>
> ----
> <clearcase-settings>
>     <viewstore>\\apxxxxx\ccviews</viewstore>
>     <useVWSParameter>false</useVWSParameter>
> </clearcase-settings>
> ----
>
> 1. When I add the project to Continuum, the server cannot find the pom.xml
> .
> This is due to the fact that the pom.xml is not directly in the working
> directory, but in a subdirectory. When I change the POM filename in the
> Continuum build definition to TEST/integration/components/MyProj/pom.xml,
> everything works fine. Is there a way to avoid this manual editing? Can
> something be specified in the POM instead?
>
> 2. The situation is worse when working with multi-module projects: When
> adding the parent POM to Continuum, also the submodules are automatically
> added. The problem is that Continuum automatically changes the SCM URL to,
> for example, scm:clearcase:\\svxxxxx\ccviews\myproj.txt/submodule1. That
> does not work, of course. To be precise, the "cleartool mkview" call
> works,
> but the "cleartool setcs" does not, because it cannot find the config
> spec.
> After changing the SCM url manually (and also the POM location in the
> build
> definition), the build still does not work. cleartool says that "A
> registry
> entry already exists for <VIEW-NAME>". This is due to the fact that the
> first mkview call was successful. So far, I was not able to resolve this.
>
> Thanks for your help!
>
> Arne
> --
> View this message in context:
> http://www.nabble.com/ClearCase-SCM-and-Continuum-t1812397.html#a4939685
> Sent from the Continuum - Users forum at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message