continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feniks Nator" <feniksena...@gmail.com>
Subject strange problem - occurs after restarting continuum
Date Fri, 16 Jun 2006 13:25:15 GMT
Hey all,

we are running continuum 1.0.3 on a windows server (2003), and we have
installed it as a service.
We have the following project structure
ROOT
- master
- module 1
- module 2
- module 3


When I restart continuum (restarting the service), I get the following error
for the all modules:

org.apache.maven.continuum.execution.ContinuumBuildExecutorException: Error
while mapping metadata.
    at
org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromCheckOut
(MavenTwoBuildExecutor.java:117)
    at
org.apache.maven.continuum.core.action.UpdateProjectFromWorkingDirectoryContinuumAction.execute
(UpdateProjectFromWorkingDirectoryContinuumAction.java:64)
    at
org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(
DefaultBuildController.java:273)
    at
org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask
(BuildProjectTaskExecutor.java:47)
    at
org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run
(ThreadedTaskQueueExecutor.java:103)
    at java.lang.Thread.run(Thread.java:534)
Caused by:
org.apache.maven.continuum.execution.maven.m2.MavenBuilderHelperException:
Cannot build maven project from D:\javadev\tools\continuum-
1.0.3\bin\win32\..\..\apps\continuum\working-directory\62\pom.xml (Cannot
find parent: mycompany.project:project-master for project:
mycompany.project:project-common:jar:3.2.8-SNAPSHOT).

    at
org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.getMavenProject
(DefaultMavenBuilderHelper.java:339)
    at
org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.mapMetadataToProject
(DefaultMavenBuilderHelper.java:112)
    at
org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromCheckOut
(MavenTwoBuildExecutor.java:113)
    ... 5 more
Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find
parent: mycompany.project:project-master for project:
mycompany.project:project-common:jar:3.2.8-SNAPSHOT
    at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(
DefaultMavenProjectBuilder.java:1161)
    at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(
DefaultMavenProjectBuilder.java:674)
    at
org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal
(DefaultMavenProjectBuilder.java:416)
    at org.apache.maven.project.DefaultMavenProjectBuilder.build(
DefaultMavenProjectBuilder.java:201)
    at
org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.getMavenProject
(DefaultMavenBuilderHelper.java:306)
    ... 7 more
Caused by: org.apache.maven.project.ProjectBuildingException: POM '
mycompany.project:project-master' not found in repository: Unable to
download the artifact from any repository

mycompany.project:project-master:pom:3.2-SNAPSHOT

from the specified remote repositories:
  central (http://repo1.maven.org/maven2)

    at
org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(
DefaultMavenProjectBuilder.java:513)
    at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(
DefaultMavenProjectBuilder.java:1157)
    ... 11 more
Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException:
Unable to download the artifact from any repository

mycompany.project:project-master:pom:3.2-SNAPSHOT

from the specified remote repositories:
  central (http://repo1.maven.org/maven2)

    at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(
DefaultArtifactResolver.java:136)
    at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(
DefaultArtifactResolver.java:63)
    at
org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(
DefaultMavenProjectBuilder.java:467)
    ... 12 more
Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to
download the artifact from any repository
    at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(
DefaultWagonManager.java:260)
    at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(
DefaultArtifactResolver.java:124)
    ... 14 more

Once the master project has been build all the modules are building normally
again.
What's very strange is that Maven is trying to go to an external repository,
while we have configured Maven to go to our internal repository:
   <profile>
      <id>dfsprofile</id>
      <repositories>
        <repository>
          <!-- must be named 'central' to override super-POM -->
          <id>central</id>
          <url>file:///\\companyserver\repo</url>
          <releases>
            <enabled>true</enabled>
        <!-- can be "always", "daily" (default), "interval:XXX" (in minutes)
or "never" (only if it doesn't exist locally) -->
            <updatePolicy>always</updatePolicy>
        <!-- Valid values are "fail" or "warn" -->
            <checksumPolicy>warn</checksumPolicy>
          </releases>
          <snapshots>
            <enabled>false</enabled>
            <updatePolicy/>
            <checksumPolicy/>
          </snapshots>
        </repository>
        <repository>
          <!-- central repository for snapshots -->
          <id>Snapshots</id>
          <name>central maven repository for snapshots</name>
          <url>file:///\\companyserver\snapshot</url>
          <releases>
            <enabled>false</enabled>
            <updatePolicy/>
            <checksumPolicy/>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>always</updatePolicy>
            <checksumPolicy>warn</checksumPolicy>
          </snapshots>
      </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <!-- central repository for snapshots (of maven plugins) -->
          <id>central</id>
          <name>central maven repository for plugins</name>
          <url>file:///\\companyserver\repo</url>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>always</updatePolicy>
            <checksumPolicy>warn</checksumPolicy>
          </releases>
          <snapshots>
            <enabled>false</enabled>
            <updatePolicy>always</updatePolicy>
            <checksumPolicy />
          </snapshots>
      </pluginRepository>
      </pluginRepositories>
    </profile>

What very strange is that when I launch the maven command (which I suppose
continuum starts) from the command line in the directory:
continuum-1.0.3\apps\continuum\working-directory\62>
all works fine.

Any ideas??

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message