continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: cvs local checkot problem
Date Thu, 22 Jun 2006 13:54:02 GMT
it seems to be a pb in maven-scm cvs provider. Can you file an issue? and I'll look at it.

The cvs provider should remove the slash at the begin of the module name.

Emmanuel

andy_rs a écrit :
> Actually that's the URL I assume is being produced by continuum when I try to
> add a multi project pom ( I don't know for sure) ... The continuum docs
> state that the module name gets appended to the scm url of the parent
> project. Since I have specified this in the parent pom..
> 
>  scm:cvs|local|s:/home/cvsroot/|
> 
> and given the resultant cvs command has a leading slash in the module name I
> just assumed that an 'effective' scm url of this form is being generated (I
> may be wrong though).
> 
> I've tried removing the trailing slash after cvsroot as well with no effect,
> and if I omit the trailing pipe character then continuum complains about an
> invalid scm url :-(
> 
> Incidentally I can get around this problem by manually adding scm urls to
> the child poms that remove the slash - i.e. 
> 
> scm:cvs|local|s:/home/cvsroot|cache
> 
> ... and adding the child poms individually. Instead of going for a
> multiproject import.
> 
> However it seem to be a very un-mavenic way of doing things ... it won't
> scale well as the number of modules grows It should be possibe to specify
> the bulk of the information in the parent pom and only the project specifics
> in the child right?
> 
> Thanks for continuing to help tho - is there anything else you think I can
> try? I'm running out of things I can think of. :-(
> 
> Cheers,
> 
> A.
> 
> 
> 
>  
> --
> View this message in context: http://www.nabble.com/cvs-local-checkot-problem-t1826113.html#a4992989
> Sent from the Continuum - Users forum at Nabble.com.
> 
> 
> 
> 


Mime
View raw message