continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: cvs local checkot problem
Date Wed, 21 Jun 2006 20:57:43 GMT
it use cvs command line because you use it in your scm url "scm:cvs..."

your scm url doesn't respect the formal of scm local provider : http://maven.apache.org/scm/local.html

Emmanuel

andy_rs a écrit :
> I'm having trouble getting a multi project build running .... my local scm
> url is ...
> 
>   <scm>
>      <connection>
>         scm:cvs|local|s:/home/cvsroot/|
>      </connection>
>   </scm>
> 
> The project pom defines a child project 'cache', which if i read the
> continuum docs correctly will get appended to the scm url. However I think
> the url is appending a leading slash to the module name, giving me something
> like ...
> 
> scm:cvs|local|s:/home/cvsroot/|/cache
> 
> (I don't know this for certain as the resultant url isn't displayed in the
> log). When it tries to checkout the project it issues the following command
> to cvs...
> 
> cvs -z3 -f -d s:/home/cvsroot/ -q checkout -d 78 /cache
> 
> ... which fails becuase of the leading slash in front of cache.
> 
> I can verify that the client fails on the comandline using this command. If
> I 'correct' the command and remove the leading slash the command completes
> as usual.
> 
> cvs -z3 -f -d s:/home/cvsroot/ -q checkout -d 78 cache
> 
> ... the checkout works fine.
> 
> INcidentally I'm having a similar problem using the release plugin in maven
> so they may be related. Might be something stupid I'm doing with the url.
> I've tried sevreal iteration and have looked at the url examples on the
> maven website - just doesn't seem to be happening :-(  Any help appreciated.
> 
> Cheers,
> 
> A.
> 
> 
> 
> --
> View this message in context: http://www.nabble.com/cvs-local-checkot-problem-t1826113.html#a4981183
> Sent from the Continuum - Users forum at Nabble.com.
> 
> 
> 
> 


Mime
View raw message