continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maksimenko Alexander <maksime...@bird.cris.net>
Subject Re: build is not finished if start executable
Date Fri, 16 Jun 2006 08:34:54 GMT
Emmanuel Venisse wrote:
> Hmm, very strange.
>
> Do you have updated your ant script? 
> http://maven.apache.org/continuum/faqs.html#how-does-continuum-detect-a-successful-build

>

yes of cause
has anybody tried to restart server in project build? I think it is 
common task for continues  integration

>
> Emmanuel
>
> Maksimenko Alexander a écrit :
>> Emmanuel Venisse wrote:
>>> BUILD SUCCESSFUL isn't a continuum message but a ant message.
>>>
>>> it's perhaps a bug in ShellCommandHelper, the exit code is return by 
>>> Process class and printed in AbstractBuildExecutor (line 189).
>>> so if you don't have "Exit code:" in your log, it's because Process 
>>> objec doesn't return it.
>>>
>>> Can you try with a non gui app?
>>
>> yes
>> the same result ;(
>>>
>>> Emmanuel
>>>
>>> Maksimenko Alexander a écrit :
>>>> Emmanuel Venisse wrote:
>>>>> if it's all your logs, the ant process isn't finished because you 
>>>>> should have "return code = 0" in log
>>>>>
>>>>
>>>> but if it's not  finished  - what does it mean BUILD SUCCESSFUL 
>>>> message in continuum's log?
>>>> if I perform this task in shell  then ant process will be finished
>>>> so may be incorrect work in ShellCommandHelper ?
>>>>
>>>> ps this log message is appear when I close calculator application
>>>>
>>>>> Emmanuel
>>>>>
>>>>> Maksimenko Alexander a écrit :
>>>>>> Emmanuel Venisse wrote:
>>>>>>> Can you send your continuum logs?
>>>>>> it's nothing odd in the log :
>>>>>>
>>>>>> INFO  Continuum                      - Enqueuing 'processbuilder'

>>>>>> (Build definition id=1).
>>>>>> INFO  ContinuumScm                   - Updating project: id: '1',

>>>>>> name 'processbuilder'.
>>>>>> INFO  ScmManager                     - Executing: svn --username

>>>>>> *** --password ***** --non-interactive update
>>>>>> INFO  ScmManager                     - Working directory: 
>>>>>> D:\tools\dev\java\jakarta\continuum\bin\win32\..\..\apps\continuum\working-directory\1

>>>>>>
>>>>>> DEBUG ScmManager                     - At revision 3172.
>>>>>> NFO  Action:update-project-from-working-directory - Updating 
>>>>>> project 'processbuilder' from checkout.
>>>>>> INFO  ShellCommandHelper             - Executing: 
>>>>>> D:\tools\dev\java\jakarta\ant\bin\ant -f build.xml continium
>>>>>> INFO  ShellCommandHelper             - Working directory: 
>>>>>> D:\tools\dev\java\jakarta\continuum\bin\win32\..\..\apps\continuum\working-directory\1

>>>>>>
>>>>>>
>>>>>>
>>>>>> my build target:
>>>>>>
>>>>>>    <target name="continium">
>>>>>>        <exec executable="cmd" dir="${engine.dir}" 
>>>>>> spawn="true">                  <arg line="/C start calc.exe"/>
>>>>>>        </exec>
>>>>>>
>>>>>>        <waitfor maxwait="30" maxwaitunit="second" 
>>>>>> timeoutproperty="server.is.unavailable">
>>>>>>              <http url="http://localhost"/>
>>>>>>        </waitfor>              <echo>finish</echo>
>>>>>>    </target>
>>>>>>
>>>>>> build result:
>>>>>>
>>>>>> Buildfile: build.xml
>>>>>>
>>>>>> continium:
>>>>>>     [echo] finish
>>>>>>
>>>>>> BUILD SUCCESSFUL
>>>>>>
>>>>>>
>>>>>> Total time: 39 seconds
>>>>>>
>>>>>>
>>>>>> but state is "Build In Progess" ;(
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>>
>>
>
>


Mime
View raw message