continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maksimenko Alexander <maksime...@bird.cris.net>
Subject Re: build is not finished if start executable
Date Thu, 15 Jun 2006 08:33:16 GMT
Emmanuel Venisse wrote:
> Can you send your continuum logs?
it's nothing odd in the log :

INFO  Continuum                      - Enqueuing 'processbuilder' (Build 
definition id=1).
INFO  ContinuumScm                   - Updating project: id: '1', name 
'processbuilder'.
INFO  ScmManager                     - Executing: svn --username *** 
--password ***** --non-interactive update
INFO  ScmManager                     - Working directory: 
D:\tools\dev\java\jakarta\continuum\bin\win32\..\..\apps\continuum\working-directory\1
DEBUG ScmManager                     - At revision 3172.
NFO  Action:update-project-from-working-directory - Updating project 
'processbuilder' from checkout.
INFO  ShellCommandHelper             - Executing: 
D:\tools\dev\java\jakarta\ant\bin\ant -f build.xml continium
INFO  ShellCommandHelper             - Working directory: 
D:\tools\dev\java\jakarta\continuum\bin\win32\..\..\apps\continuum\working-directory\1


my build target:

    <target name="continium">
        <exec executable="cmd" dir="${engine.dir}" spawn="true">       
            <arg line="/C start calc.exe"/>
        </exec>

        <waitfor maxwait="30" maxwaitunit="second" 
timeoutproperty="server.is.unavailable">
              <http url="http://localhost"/>
        </waitfor>       
        <echo>finish</echo>
    </target>

build result:

Buildfile: build.xml

continium:
     [echo] finish

BUILD SUCCESSFUL


Total time: 39 seconds


but state is "Build In Progess" ;(

Mime
View raw message