continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maksimenko Alexander <maksime...@bird.cris.net>
Subject start executable from ant
Date Tue, 13 Jun 2006 13:11:29 GMT
thank you!
have not seen this faq yet
have another problem -
i need restart jboss after successful build
but continuous  build is not marked successful until jboss process is 
not finished
this is scratch from my ant.bat :

<exec executable="${engine.dir}/jboss-3.2.7/bin/run.bat" 
dir="${engine.dir}/jboss-3.2.7/bin" spawn="true" vmlauncher="false"/>

it's interesting but if i run this task from eclipse, this task is 
marked finished immediately after process was started

> You need to modify ant script.
>
> http://maven.apache.org/continuum/faqs.html#how-does-continuum-detect-a-successful-build

>
>
> Emmanuel
>
> Maksimenko Alexander a écrit :
>>  hi!
>> I've got some strange behavior :
>> after building mine ant project I've got  "success"  status but  in  
>> output i see
>>
>> deploy:
>>   [delete] Deleting directory 
>> jboss-3.2.7\server\default\deploy\workflow.ear
>>
>> BUILD FAILED
>> working-directory\1\build.xml:140: The following error occurred while 
>> executing this line:
>> working-directory\1\build.xml:123: Unable to delete file 
>> jboss-3.2.7\server\default\deploy\workflow.ear\processbuilder.war\WEB-INF\lib\activation.jar

>>
>>
>> Total time: 19 seconds
>>
>>
>>
>> so the build is actually failed
>>
>> here is the scartch from ant file:
>>
>> - 
>> <mailbox:///C%7C/Documents%20and%20Settings/sasha/Application%20Data/Thunderbird/Profiles/u8d30cg2.default/Mail/bird.cris.net/Sent?number=19645#>

>> <target name="*continium*">
>>      <antcall target="*create*" />
>>      <antcall target="*deploy*" />
>> </target>
>>
>> am I missed something?
>>
>>
>>
>>
>
>


Mime
View raw message