continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Perham" <Mike.Per...@webifysolutions.com>
Subject RE: tag while using Perforce fails if label already exists
Date Wed, 31 May 2006 18:42:20 GMT
Nope.  Feel free to enter a JIRA issue.  I hit that bug myself
yesterday.  In the meantime, 'p4 label -d foo' will workaround the
problem.

-----Original Message-----
From: Smythe, Steve [mailto:Steve_Smythe@intuit.com] 
Sent: Wednesday, May 31, 2006 1:31 PM
To: 'continuum-users@maven.apache.org'
Cc: Smythe, Steve
Subject: scm:tag while using Perforce fails if label already exists

scm:tag while using Perforce fails if label already exists.

C:\p4dev\users\ssmythe\maven2\test>mvn -Dtag=foo scm:tag [INFO] Scanning
for projects...
[INFO] Searching repository for plugin with prefix: 'scm'.
[INFO]
------------------------------------------------------------------------
----
[INFO] Building Test Maven2 Project
[INFO]    task-segment: [scm:tag]
[INFO]
------------------------------------------------------------------------
----
[INFO] [scm:tag]
[ERROR] Provider message:
[ERROR] Tag failed
[ERROR] Command output:
[ERROR] Label foo not changed.

[INFO]
------------------------------------------------------------------------
----
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
----
[INFO] Command failed.Tag failed
[INFO]
------------------------------------------------------------------------
----
[INFO] For more information, run Maven with the -e switch [INFO]
------------------------------------------------------------------------
----
[INFO] Total time: 3 seconds
[INFO] Finished at: Wed May 31 11:08:10 PDT 2006 [INFO] Final Memory:
3M/7M [INFO]
------------------------------------------------------------------------
----

Is there a way to ignore this error?  Like set some property
-Dtag.error.ignore=true or something like that?

Steve


Mime
View raw message