continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lee Meador" <...@leemeador.com>
Subject Removed test still running
Date Fri, 03 Mar 2006 17:52:41 GMT
I don't know quite what all is going on here but thought I'd at least
document what is happening since it took me a while to figure out.

I had a class in one project/jar and moved it to another project/jar. (I'll
call it Lookup.java.)I had to straighten up some dependencies to make it
work but that's the way it goes. There was a test for that class that I
moved as well.

Continuum had built the projects (they were both subprojects of my parent
project) prior to the change. When I checked in the changes, the Lookup.javaand
LookupTest.java were deleted in one project and added in another. When
Continuum ran after the checkin the class file for LookupTest was still in
the target test classes and that test got run. Since it was supposed to be
in the other project now (along with other classes on which it depended) it
failed all 16 tests.

The same thing did not happen when I ran the same build from inside Eclipse.
I use the external builds to run mvn.bat directly and not the maven eclipse
plugin's build (which doesn't seem to work at all for me). My memory is not
perfect but I don't beleive I have done a clean there.

I have changed the maven target from "install" to "clean install" and it
gets past that point now. (Of course, that revealed another problem with
another part of my build. It's good to know these things though.)

As I was typing, I found that other problem and things build now.


-- Lee Meador
Sent from gmail. My real email address is lee@leemeador.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message