continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian E. Fox" <bri...@reply.infinity.nu>
Subject RE: Continuum build failure
Date Wed, 01 Feb 2006 18:59:18 GMT
Yes it's the parent. Here's the text of that pom:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>

  <parent>
    <groupId>com.stchome.modules.applications.dsms</groupId>
    <artifactId>parent</artifactId>
    <version>2.1.0.2-SNAPSHOT</version>
  </parent>

  <name>DSMS Legacy Parent Pom</name>
  <groupId>com.stchome.modules.applications.dsms.legacy</groupId>
  <artifactId>legacy</artifactId>
  
  <packaging>pom</packaging>
  
  <dependencyManagement>
    <dependencies>
         <dependency>
           <groupId>com.stchome.non-maven</groupId>
           <artifactId>MPI</artifactId>
           <version>1.6.0.2</version>
            <scope>compile</scope>
         </dependency>
    </dependencies>
  </dependencyManagement>
 <modules>
   <module>hl7</module>
   <module>nbs</module>
   <module>security</module>
   <module>case-assignment</module>
   <module>warehouse</module>
   <module>cdr-legacy</module>
   <module>user-management-struts</module>
   <module>cdr-ui</module>
 </modules>

</project>


I'm not sure where to find the log though, it's not in the cont-out-dir\28\ 

-----Original Message-----
From: Emmanuel Venisse [mailto:emmanuel@venisse.net] 
Sent: Wednesday, February 01, 2006 12:28 PM
To: continuum-users@maven.apache.org
Subject: Re: Continuum build failure

Can you check your pom in d:\builds\cont-work-dir\28\? Is it the parent?

If not, file an issue with more explanations of the problem and the full trace of project
build

Emmanuel

Brian E. Fox a écrit :
> I just incremented all my versions on a branch in continuum and 
> expected that it would build automatically. It appears something is 
> really wierd because when attempting to build the parent, it is trying 
> to find itself in the repository. What's up with that? If I build 
> manually, it's fine.
> org.apache.maven.continuum.execution.ContinuumBuildExecutorException:
> Error while mapping metadata.
> 	at
> org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.up
> da
> teProjectFromCheckOut(MavenTwoBuildExecutor.java:120)
> 	at
> org.apache.maven.continuum.core.action.UpdateProjectFromWorkingDirecto
> ry 
> ContinuumAction.execute(UpdateProjectFromWorkingDirectoryContinuumActi
> on
> .java:62)
> 	at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.buil
> d(
> DefaultBuildController.java:169)
> 	at
> org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.ex
> ec
> uteTask(BuildProjectTaskExecutor.java:53)
> 	at
> org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$Exec
> ut
> orRunnable.run(ThreadedTaskQueueExecutor.java:103)
> 	at java.lang.Thread.run(Thread.java:534)
> Caused by:
> org.apache.maven.continuum.execution.maven.m2.MavenBuilderHelperExcept
> io
> n: Cannot build maven project from d:\builds\cont-work-dir\28\pom.xml.
> 	at
> org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.
> getMavenProject(DefaultMavenBuilderHelper.java:268)
> 	at
> org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.
> mapMetadataToProject(DefaultMavenBuilderHelper.java:89)
> 	at
> org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.up
> da
> teProjectFromCheckOut(MavenTwoBuildExecutor.java:116)
> 	... 5 more
> Caused by: org.apache.maven.project.ProjectBuildingException: POM 
> 'com.stchome.modules.applications.dsms:parent' not found in repository:
> Unable to download the artifact from any repository
>   com.stchome.modules.applications.dsms:parent:2.1.0.2-SNAPSHOT:pom
> 
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2)
> 
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepos
> it
> ory(DefaultMavenProjectBuilder.java:423)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(De
> fa
> ultMavenProjectBuilder.java:955)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMaven
> Pr
> ojectBuilder.java:586)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFil
> e(
> DefaultMavenProjectBuilder.java:298)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMaven
> Pr
> ojectBuilder.java:283)
> 	at
> org.apache.maven.continuum.execution.maven.m2.DefaultMavenBuilderHelper.
> getMavenProject(DefaultMavenBuilderHelper.java:260)
> 	... 7 more
> Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException:
> Unable to download the artifact from any repository
>   com.stchome.modules.applications.dsms:parent:2.1.0.2-SNAPSHOT:pom
> 
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2)
> 
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(Def
> au
> ltArtifactResolver.java:136)
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(Def
> au
> ltArtifactResolver.java:63)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepos
> it
> ory(DefaultMavenProjectBuilder.java:380)
> 	... 12 more
> Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: 
> Unable to download the artifact from any repository
> 	at
> org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(Defa
> ul
> tWagonManager.java:260)
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(Def
> au
> ltArtifactResolver.java:124)
> 	... 14 more
> 




Mime
View raw message