continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pherto...@mmm.com
Subject Re: connection to cvs error
Date Thu, 01 Dec 2005 16:07:30 GMT
Emmanuel,

this is what I've checked so far:

there is a cvspass key in windows XP registry, showing key 
:pserver:myusername@cvsserver:D:/dept/xxxx with my encoded password value. 
Notice that the CVSROOT url is given with : (colon) instead of | (pipe)

In the pom.xml, the scm url is defined as: 
        scm|cvs|pserver|myusername@cvsserver|D:/dept/xxxx|testMaven

Trying to build in this configuration, I still get the "password required" 
error.

When I try to use this scm url: 
        scm:cvs:pserver:myusername@cvsserver:D:/dept/xxxx:testMaven

I get following error:
 
java.lang.NumberFormatException: For input string: "D"
        at 
java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
        at java.lang.Integer.parseInt(Integer.java:468)
        at java.lang.Integer.(Integer.java:609)
        at 
org.apache.maven.scm.provider.cvslib.CvsScmProvider.parseScmUrl(CvsScmProvider.java:320)
        at 
org.apache.maven.scm.provider.cvslib.CvsScmProvider.validateScmUrl(CvsScmProvider.java:152)
        at 
org.apache.maven.scm.manager.plexus.DefaultScmManager.validateScmRepository(DefaultScmManager.java:208)
        at 
org.apache.maven.continuum.web.validation.ScmUrlValidator.validate(ScmUrlValidator.java:40)

Using the cvs manual login command, I can't enter a CVSROOT url using 
pipes instead of colons. 

What's more, when in the web interface I try to edit the scm url, using 
pipes, I get the error that the scm url is not valid, so it seems that the 
scm url using pipes is not passing validation.....

Could it be that there is a problem with the : colon versus | pipe in the 
scm url? 

Anybody already running continuum 1.0.1 using maven1 and cvsnt and windows 
cvs server?

Thanks again,
Peter






Emmanuel Venisse <emmanuel@venisse.net> 
01/12/2005 15:33
Please respond to
continuum-users@maven.apache.org


To
continuum-users@maven.apache.org
cc

Subject
Re: connection to cvs error






cvsnt doesn't use cvs standard to store password. It use windows registry 
and we can't access to it, 
so you need to run cvs login command manually to register your password.

Emmanuel

phertogen@mmm.com a écrit :
> I got a problem when trying to build a Maven1 project.
> 
> I just uploaded the pom.xml and tried to build. 
> 
> This is the build error as shown in web interface:
> 
> Exception: 
> Cannot checkout sources. 
> Exception while executing SCM command. 
> password is required
> 
> I am running Continuum 1.0.1 locally on windows XP. Cvs servers is 
running 
> on Windows server. Client is cvsnt.
> 
> This is my scm url, as defined in the POM :
> 
> scm|cvs|pserver|myusername@cvfsserver|D:/dept/xxxxxx|testMaven
> 
> I can connect to cvs server via eclipse, directly or via Mevenide. 
> 
> Can I help Continuum to find my scm settings?
> 
> tx,
> Peter



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message