continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Zhao" <Frank.Z...@motricity.com>
Subject RE: Errors when starting Continuum which is built on my machine
Date Wed, 02 Nov 2005 20:20:15 GMT

We tried it on Windows today and got the same error. Could it be possible that some files
are mismatched recently, but you have the correct files cached on your machine?

Thanks,

Frank


-----Original Message-----
From: Emmanuel Venisse [mailto:emmanuel@venisse.net]
Sent: Tue 11/1/2005 4:55 PM
To: continuum-users@maven.apache.org
Subject: Re: Errors when starting Continuum which is built on my machine
 
I don't have this problem on my windows machine but we have the same problem on continuous

integration machine. I'll look at log4j jar for see if it's wrong.

Emmanuel

Frank Zhao a écrit :
> On Linux machine, I check out the Continuum trunk from the svn repository, run "./build.sh",
the compilation was OK (with a few test failure). 
> 
> Then followed the README file, under the "continuum-plexus-application/target/plexus-test-runtime/",
I ran "./bin/plexus.sh", I got the following errors:
> 
> Exception in thread "main" java.lang.NoSuchMethodError: java.lang.IllegalArgumentException:
method <init>(Ljava/lang/String;Ljava/lang/Throwable;)V not found
>         at org.codehaus.plexus.logging.log4j.Log4JLoggerManager.initialize(Log4JLoggerManager.java:202)
>         at org.codehaus.plexus.personality.plexus.lifecycle.phase.InitializePhase.execute(InitializePhase.java:16)
>         at org.codehaus.plexus.lifecycle.AbstractLifecycleHandler.start(AbstractLifecycleHandler.java:101)
>         at org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:105)
> ...
> ...
> 
> 
> I couldn't find the "Log4JLoggerManager.java" on my machine. It seems the jar containing
the Log4JLoggerManager.class is in the wrong version or mismatched with other classes and
therefore caused the "NoSuchMethodError".
> 
> Is there anyone on this list who recently build Continuum 1.0 on Linux? I have been working
on this for a week and have no idea how to make it work.
> 
> Thanks in advance!
> 
> Frank
> 
> 
> 



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message