continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Doran <eli.do...@gmail.com>
Subject Continuum 1.0 Final switch from 1.0-beta-1
Date Fri, 28 Oct 2005 00:30:39 GMT
Is there some documentation somewhere about the fields requested when 
adding a project?  My problem is the Maven SCM URL's I used with 
1.0-beta-1 do not work with 1.0 Final. Since the final version has a few 
more fields to fill in I am thinking the problem is because I'm not 
putting the correct stuff in them. I use Subversion and Ant projects. 
When checking the continuum.log it shows that the SVN command is not 
using the right repository path. it is just using "/". 

my scm url:  scm:svn:file:///opt/svn/store/public/test-project/present
repo: /opt/svn/store/public
project: test-project
trunk ~ present

important logged lines:
Command line: svn --non-interactive checkout / 6
Command output: svn: '/' does not appear to be a URL

logged error:
966094 [Thread-2] INFO  org.apache.maven.continuum.scm.ContinuumScm  - 
Checking out project: 'TestProject', id: '6' to '/opt/cont
inuum/1.0/bin/linux/../../apps/continuum/working/6' with branch/tag .
966096 [Thread-2] INFO  org.apache.maven.scm.manager.ScmManager  - 
Working directory: 
/opt/continuum/1.0/bin/linux/../../apps/continuum/working/6
966096 [Thread-2] INFO  org.apache.maven.scm.manager.ScmManager  - 
Command line: svn --non-interactive checkout / 6
967241 [Thread-2] WARN  org.apache.maven.continuum.scm.ContinuumScm  - 
Error while checking out the code for project: 'TestProject', id: '6' to 
'/opt/continuum/1.0/bin/linux/../../apps/continuum/working/6' with 
branch/tag .
967241 [Thread-2] WARN  org.apache.maven.continuum.scm.ContinuumScm  - 
Command output: svn: '/' does not appear to be a URL
967241 [Thread-2] WARN  org.apache.maven.continuum.scm.ContinuumScm  - 
Provider message: The svn command failed.

-----------------------------------------------------------------------------------------

Also, when I use "YOUKNOW/continuum" in the browser it redirects me to 
"YOUKNOW/servlet/continuum" which is incorrect. I just use 
"YOUKNOW/continuum/servlet/continuum" and everything works fine. I use 
Apache's web server as the front end with the proxy configuration lines 
provided in the Continuum documentation.

~eli

Mime
View raw message