continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barrow, Zach" <zbar...@systechnologies.com>
Subject Continuum not recognizing maven exit code
Date Fri, 28 Oct 2005 23:58:57 GMT
I've read up on the site and added exit /B %ERRORLEVEL% to my maven.bat
file (although the documentation says exit /B errorlevel), and have even
echoed the result to see what error code is getting returned, and it
should be returning 70 to Continuum.  However, Continuum is still giving
a build successful result.  Any ideas?  Here's my environment:

Windows XP SP2
Java 1.5
Maven version 1.0.2
Continuum version 1.0

edited maven.bat
------------------------
...
@REM pause the batch file if MAVEN_BATCH_PAUSE is set to 'on'
if "%MAVEN_BATCH_PAUSE%" == "on" pause
exit /B %ERRORLEVEL%
------------------------

Continuum wrapper.log
------------------------
...
INFO   | jvm 2    | 2005/10/28 16:48:50 | 2005-10-28 16:48:50,883
[Thread-1] INFO  Action:update-project-from-working-directory - Updating
project 'commplanner' from checkout.
INFO   | jvm 2    | 2005/10/28 16:48:51 | 2005-10-28 16:48:51,213
[Thread-1] WARN  ContinuumBuildExecutor:maven-1 - Executable
'c:\apps\Maven-1.0\bin\maven'.
INFO   | jvm 2    | 2005/10/28 16:48:51 | 2005-10-28 16:48:51,213
[Thread-1] INFO  ContinuumBuildExecutor:maven-1 - Arguments: -o
-Duser.home=c:/cygwin/home/zbarrow clean:clean multiproject:install
INFO   | jvm 2    | 2005/10/28 16:48:51 | 2005-10-28 16:48:51,213
[Thread-1] INFO  ContinuumBuildExecutor:maven-1 - Working directory:
c:\apps\continuum-1.0\bin\win32\..\..\apps\continuum\working-directory\6
2
INFO   | jvm 2    | 2005/10/28 16:49:56 | 2005-10-28 16:49:56,558
[Thread-1] INFO  ContinuumBuildExecutor:maven-1 - Exit code: 0
INFO   | jvm 2    | 2005/10/28 16:49:57 | 2005-10-28 16:49:57,049
[Thread-1] INFO  Notifier:mail                  - Current build state:
2, previous build state: 2
INFO   | jvm 2    | 2005/10/28 16:49:57 | 2005-10-28 16:49:57,049
[Thread-1] INFO  Notifier:mail                  - Same state, not
sending mail.
INFO   | jvm 2    | 2005/10/28 16:50:25 | 2005-10-28 16:50:25,120
[SocketListener0-1] ERROR VelocityComponent              - RHS of #set
statement is null. Context will not be modified. screens/ProjectBuild.vm
[line 73, column 3]
------------------------

I notice in the log that ContinuumBuildExecutor returns Exit code: 0,
even though maven is returning exit code 70 for my build.

Thanks for any help,
Zach

Mime
View raw message