continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: SPAM: Problem with authenticated POM URLs
Date Tue, 20 Sep 2005 13:52:20 GMT
No, sorry. alpha-4 release is in construction. It will be for beta-1

Emmanuel

Mark Hobson wrote:
> Hi Emmanuel,
> 
> I found the problem deep within plexus, see:
> 
> http://jira.codehaus.org/browse/PLX-157
> 
> Do you think this will get in for alpha4?
> 
> Cheers,
> 
> Mark
> 
> On 20/09/05, Emmanuel Venisse <emmanuel@venisse.net> wrote:
> 
>>Hi Mark,
>>
>>authorized urls are http[s]://[username:password@]domain/urel/to/pom.xml
>>
>>I think your url was incorrect because continuum couldn't download it ("The URL you
>>provided doesn't exist"). Try to obtain the correct url in your browser and then put
it in
>>continuum.
>>
>>Do you have a particular authentication mode on your server?
>>
>>If it doesn't work, you can upload your pom.
>>
>>Emmanuel
>>
>>Mark Hobson wrote:
>>
>>>Hi there,
>>>
>>>I'm having problems with authenticated POM URLs with the build
>>>continuum-20050920.033000.tar.gz.  Our SVN repository is accessible
>>>via authenticated https and authenticated http internally, so I've
>>>been trying the following and get the corresponding errors:
>>>
>>>https://my.domain/url/to/pom.xml
>>>"The URL you provided doesn't exist"
>>>
>>>https://username@my.domain/url/to/pom.xml
>>>"You must provide a valid url"
>>>
>>>https://username:password@my.domain/url/to/pom.xml
>>>"The URL you provided doesn't exist"
>>>
>>>http://my.domain/url/to/pom.xml
>>>"The URL you provided doesn't exist"
>>>
>>>http://username@my.domain/url/to/pom.xml
>>>"You must provide a valid url"
>>>
>>>http://username:password@my.domain/url/to/pom.xml
>>>"The URL you provided doesn't exist"
>>>
>>>There are no errors in the logs (aside from the side-issue of:
>>>
>>>WARN VelocityComponent -
>>>org.apache.velocity.runtime.exception.ReferenceException: reference :
>>>template = screens/AddMavenProject.vm [line 1,column 16] :
>>>$fvr.getElementResult( $element.getId() ).errorMessage is not a valid
>>>reference.
>>>
>>>which causes "[ $fvr.getElementResult( $element.getId() ).errorMessage
>>>]" to be displayed as the validation message alongside the upload POM
>>>field).
>>>
>>>I see from CONTINUUM-306 that https should be supported - am I doing
>>>anything wrong?
>>>
>>>Cheers,
>>>
>>>Mark
>>>
>>>
>>
>>
> 
> 


Mime
View raw message