continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brent N Atkinson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONTINUUM-2757) Not Java8 compliant
Date Sun, 26 Apr 2015 14:59:38 GMT

    [ https://issues.apache.org/jira/browse/CONTINUUM-2757?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14513065#comment-14513065
] 

Brent N Atkinson commented on CONTINUUM-2757:
---------------------------------------------

The current development version uses a more recent version of Spring and does not suffer from
this issue. However, it appears that there are more issues preventing running under Java 8:

  * the version of bcel used to enhance the jpox model classes doesn't understand the Java
8 class file format completely
  * JSP compilation fails due to references to the older java.util.Map

These may be fixed by:

 * Using an updated version of bcel during enhancement (bcel 6 is not released, but com.google.code.findbugs:bcel-findbugs:6.0
worked)
 * Recompiling redback under Java 7+, however this is difficult due to the project's current
status. Ultimately, there are multiple reasons for replacing redback, including better authentication
support.

> Not Java8 compliant
> -------------------
>
>                 Key: CONTINUUM-2757
>                 URL: https://issues.apache.org/jira/browse/CONTINUUM-2757
>             Project: Continuum
>          Issue Type: Bug
>          Components: Environmental
>    Affects Versions: 1.4.2
>         Environment: Windows 8, Java 8, Tomcat 8
>            Reporter: Alexandre Trovato
>              Labels: java, spring
>             Fix For: 1.5.0, 1.4.3
>
>
> The Spring framework (version 2.x) is not Java 8/Tomcat 8 compliant.
> This error occurs :
> Caused by: java.lang.IllegalStateException: Context namespace element 'annotation-config'
and its parser class [org.springframework.context.annotation.AnnotationConfigBeanDefinitionParser]
are only available on JDK 1.5 and higher.
> Please see : https://jira.spring.io/browse/SPR-11899
> I hope I'm clear enougth.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message