continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vishnu Raj (JIRA)" <j...@codehaus.org>
Subject [jira] (CONTINUUM-2712) Release issue :: Unable to release components
Date Thu, 03 Oct 2013 06:56:52 GMT

    [ https://jira.codehaus.org/browse/CONTINUUM-2712?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=333563#comment-333563
] 

Vishnu Raj edited comment on CONTINUUM-2712 at 10/3/13 1:55 AM:
----------------------------------------------------------------

Thanks for the reply Brent.

I have cross checked all JDK versions, compiled the components under JDK 5 many times and
still, the same error.

- I am using JDK 5 out of necessity. I tried with JDK 6 as well and the same exception was
thrown at that time also.
- My buiild does not use jetty, but there are some cases where jetty-maven-plugin is been
used in the POM files, in case if we use a jetty server.
- I have also tried with the release of components which doesnot have any jetty plugin included
in it. Those component doesn't even have any dependency in any other components which have
'jetty plugin' defined. Even at that case, it throwed the same exception.




                
      was (Author: vichukailas):
    Thanks for the reply Brent.

I have cross checked all JDK versions, compiled the components under JDK 5 many times and
still, the same error.

-I am using JDK 5 out of necessity. I tried with JDK 6 as well and the same exception was
thrown at that time also.
-My buiild does not use jetty, but there are some cases where jetty-maven-plugin is been used
in the POM files, in case if we use a jetty server.
- I have also tried with the release of components which doesnot have any jetty plugin included
in it. Those component doesn't even have any dependency in any other components which have
'jetty plugin' defined. Even at that case, it throwed the same exception.




                  
> Release issue :: Unable to release components
> ---------------------------------------------
>
>                 Key: CONTINUUM-2712
>                 URL: https://jira.codehaus.org/browse/CONTINUUM-2712
>             Project: Continuum
>          Issue Type: Bug
>          Components: Release
>    Affects Versions: 1.4.1
>         Environment: OS: Linux
> Server: Tomcat 6.0.35
> Apache Maven 2.2.1
> JDK 1.5
>            Reporter: Vishnu Raj
>         Attachments: Continuum-Release Issue.txt
>
>
> While performing release, exception is being thrown by the Continuum build agent saying
"java.lang.UnsupportedClassVersionError: Bad version number in .class file (unable to load
class org.eclipse.jetty.util.security.Password)"
> I am new to Contiuum and setting it up for the first time. Any help in this would be
greatly appreciated. Thanks in advance.
> Attached the log file. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message