continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maria Catherine Tan (JIRA)" <>
Subject [jira] Closed: (CONTINUUM-2131) An unconfigured build agent should not be enabled
Date Sat, 23 Jul 2011 11:25:42 GMT


Maria Catherine Tan closed CONTINUUM-2131.

    Resolution: Fixed

fixed in r1150083 and r1150084
* build agent will not respond to master's ping if it isn't configured properly e.g. continuumServerUrl
is empty or points to a different url
* show error message in UI

> An unconfigured build agent should not be enabled
> -------------------------------------------------
>                 Key: CONTINUUM-2131
>                 URL:
>             Project: Continuum
>          Issue Type: Improvement
>    Affects Versions: 1.3.2 (Beta)
>            Reporter: Wendy Smoak
>            Assignee: Maria Catherine Tan
>             Fix For: 1.4.1 (Beta)
> I noticed that when I added a build agent that I had installed and started, (but not
configured by adding the necessary items to buildagent-configuration.xml,) it responded to
the ping and showed as 'enabled' in the master.
> Without the master url it has no chance of actually working, so I think it shouldn't
respond to the ping.  Not being able to 'enable' it should cause the admin to go looking for
the problem.
> This might be fixed by a related issue, that an agent should only respond to its configured
master.  If there is no master configured, then it shouldn't be talking to anyone.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message