continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Walker (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (CONTINUUM-2049) ClassCastException deploying Continuum.war on JBoss-5.0.0.GA
Date Tue, 27 Jan 2009 16:53:19 GMT
ClassCastException deploying Continuum.war on JBoss-5.0.0.GA
------------------------------------------------------------

                 Key: CONTINUUM-2049
                 URL: http://jira.codehaus.org/browse/CONTINUUM-2049
             Project: Continuum
          Issue Type: Bug
          Components: Environmental
    Affects Versions: 1.2.3
         Environment: Windows Server 2003 R2 and XP SP3,  Sun JDK JVM 1.6.0_11, running JBoss
5.0.0.GA 
            Reporter: Bob Walker
            Priority: Minor
         Attachments: stacktrace.txt

I'm launching the default server configuration for a clean JBoss 5.0.0.GA installation and
deploying continuum.war into the deploy/ directory. 

Having tried to adapt the instructions for 4.x.x here:

http://docs.codehaus.org/display/CONTINUUMUSER/Continuum+on+JBoss

, I've set up data sources and made the derby jar available.

When I start the server or redeploy, I get a ClassCastException: org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
cannot be cast to javax.xml.parsers.DocumentBuilderFactory

I tried removing log4j and some of the xml-related jars as described in the Archiva/JBoss
doc here:

http://cwiki.apache.org/ARCHIVA/archiva-on-jboss.html

This gets me further, but fails with the same error when loading spring context configuration
further down the road.

I've also tried removing xalan/xerces and letting it use the default endorsed version supplied
by JBoss, this gives me different ClassLoader errors, at which point I gave up and began writing
my findings here.

I'm guessing it's a fairly simple classloader issue with xalan and xerces, but it's got me
stumped. Any hints? I've tried it with v1.3.1 as well, with the same result.


 
 



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message