continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-1953) [regression] Build definitions not linked when creating a new project with a given build defintion template
Date Sun, 14 Dec 2008 15:12:19 GMT

    [ http://jira.codehaus.org/browse/CONTINUUM-1953?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=157944#action_157944
] 

Olivier Lamy commented on CONTINUUM-1953:
-----------------------------------------

Does it happened when you add the project to an existing project group (an empty project group)
?
I should say it's normal because when you create an empty project group the default m2 buiid
def is associated to this new project group.
I have created a unit test in core (src/test/java/org/apache/maven/continuum/AddMaven2ProjectTest.java)
which check four cases :
- adding a project with a template to an existing projectGroup
- adding a project without a template to an existing projectGroup
- adding a project with a template with auto projectGroup creation
- adding a project without a template  with auto projectGroup creation

comment added in the unit rev 726462.

IMHO We should add a new feature : creating project group with a build template 

> [regression] Build definitions not linked when creating a new project with a given build
defintion template
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: CONTINUUM-1953
>                 URL: http://jira.codehaus.org/browse/CONTINUUM-1953
>             Project: Continuum
>          Issue Type: Bug
>          Components: Web - Configuration
>    Affects Versions: 1.2
>         Environment: Linux / Java 1.6.0_10 / mvn 2.0.9
>            Reporter: Jean-Paul GUIGUI
>            Assignee: Olivier Lamy
>             Fix For: 1.2.3
>
>
> When adding a new Maven2 project with the Web interface, I'm associating the project
with a given BuildDefinitionTemplate.
> The project is created but no build definition is associated to the project. I need to
associate all the build definitions of the template manually to the project.
> It looks like the function AddMavenProjectAction.setBuildDefinitionTemplateId() is never
called.
> I have migrated from Continuum 1.1 to 1.2 . It used to work in previous version.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message