continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Guther (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-1054) IllegalStateException stack adding pom
Date Thu, 30 Oct 2008 00:10:51 GMT

    [ http://jira.codehaus.org/browse/CONTINUUM-1054?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=152373#action_152373
] 

Andreas Guther commented on CONTINUUM-1054:
-------------------------------------------

We did some more experimenting and it appears that Continuum is able to retrieve the pom file
via HTTP.

What we believe now is that we had an issue with the used password for our SVN server that
ended with an exclamation point "!".  I tried to checkout the project on command line with
the --password argument to SVN and got some errors.  I omitted then passing the password as
argument and had to enter the password after SVN asked me for it.  That finally triggered
the checkout.

I think this is rather a shell problem.  However, the error message provided by Continuum
is very misleading and since I found the same error messages described  in this issue in our
log file I was wrongly concluding that I am facing the same problem.

I guess I will open a new issue describing the actual problem and the possible cause.

> IllegalStateException stack adding pom
> --------------------------------------
>
>                 Key: CONTINUUM-1054
>                 URL: http://jira.codehaus.org/browse/CONTINUUM-1054
>             Project: Continuum
>          Issue Type: Bug
>          Components: Web interface
>    Affects Versions: 1.1-alpha-1
>            Reporter: Carlos Sanchez
>            Assignee: Brett Porter
>            Priority: Minor
>             Fix For: 1.2
>
>
> Adding a m2 pom from a web location causes this stack trace, although seems to work fine
> 2006-12-13 10:46:07,109 [SocketListener0-1] INFO  DispatcherUtils                - Unable
to find 'webwork.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir
> 2006-12-13 10:46:07,156 [SocketListener0-1] WARN  MultiPartRequest               - Item
is a file upload of 0 size, ignoring
> 2006-12-13 10:46:07,156 [SocketListener0-1] ERROR DispatcherUtils                - Error
setting character encoding to 'UTF-8' - ignoring.
> java.lang.IllegalStateException: getReader() or getInputStream() called
>         at org.mortbay.jetty.servlet.ServletHttpRequest.setCharacterEncoding(ServletHttpRequest.java:602)
>         at javax.servlet.ServletRequestWrapper.setCharacterEncoding(ServletRequestWrapper.java:112)
>         at com.opensymphony.webwork.dispatcher.DispatcherUtils.prepare(DispatcherUtils.java:392)
>         at com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:160)
>         at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
>         at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
>         at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
>         at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
>         at com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:88)
>         at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplicationHandler.java:821)
>         at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:471)
>         at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
>         at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
>         at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
>         at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
>         at org.mortbay.http.HttpServer.service(HttpServer.java:909)
>         at org.mortbay.http.HttpConnection.service(HttpConnection.java:816)
>         at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:982)
>         at org.mortbay.http.HttpConnection.handle(HttpConnection.java:833)
>         at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)
>         at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
>         at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message