continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak (JIRA)" <>
Subject [jira] Commented: (CONTINUUM-1675) Improve error message when scm element is missing from a child pom
Date Wed, 17 Sep 2008 22:28:48 GMT


Wendy Smoak commented on CONTINUUM-1675:

The "Missing 'scm' element in the POM, projet {0}" message is happening when the scm information
is _completely_ missing from the project.  (No scm element in the parent pom I'm trying to
add using a url.)

That's different from the original issue here, which was about the scm element missing from
a _child_ pom.

However, I think the broken message is related to the fix for this issue.  Let me know if
you want me to open a separate JIRA for it.

> Improve error message when scm element is missing from a child pom
> ------------------------------------------------------------------
>                 Key: CONTINUUM-1675
>                 URL:
>             Project: Continuum
>          Issue Type: Improvement
>          Components: Web - UI
>    Affects Versions: 1.1
>            Reporter: Wendy Smoak
>            Priority: Minor
>             Fix For: 1.2
> When adding a multi-module project, if one of the child projects does not have a scm
element, I still get the generic message:
> "Missing 'scm' element in the POM."
> In the log file, I can see that it knows exactly which pom is missing the element:
> INFO   | jvm 1    | 2008/02/25 11:16:35 | 2008-02-25 11:16:35,530 [SocketListener0-7]
ERROR MavenBuilderHelper:default     - Missing 'scm' element in the ExampleWebapp POM.
> (This happened because the child project did not have a <parent> element.)
> The web page should display the more specific error message.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message