continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lorand Somogyi (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (CONTINUUM-1739) Import of Maven2 project fails if 2.0.9 feature depMgm. scope>import used
Date Tue, 22 Apr 2008 12:57:55 GMT
Import of Maven2 project fails if 2.0.9 feature depMgm. scope>import used
-------------------------------------------------------------------------

                 Key: CONTINUUM-1739
                 URL: http://jira.codehaus.org/browse/CONTINUUM-1739
             Project: Continuum
          Issue Type: Bug
          Components: Integration - Maven 2
    Affects Versions: 1.1
         Environment: Linux RedHat 2.6.18-53.1.14.el5, 
Sun JDK 1.5 and JDK 1.6. 
Maven 2.0.9, 
Continuum 1.1
            Reporter: Lorand Somogyi
            Priority: Blocker


Import of Maven2 project fails if 2.0.9 feature "importing managed dependencies" is used.
If the project is already imported it will fail saying there is no pom.xml. 

Example:

pom.xml excerpt: 
	<dependencyManagement>
		<dependencies>
			<dependency>
				<groupId>com.example</groupId>
				<artifactId>ext-deps</artifactId>
				<version>RELEASE</version>
				<type>pom</type>
				<scope>import</scope>
			</dependency>
		</dependencies>
	</dependencyManagement>

Workaround: we use parent now instead.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message