continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <>
Subject [jira] Closed: (CONTINUUM-1595) Unable to find the mojo when run from continuum
Date Wed, 02 Apr 2008 05:25:58 GMT


Brett Porter closed CONTINUUM-1595.

    Resolution: Won't Fix

this looks like a version conflict that results from the way Maven is used. Try adding theversions
to the Maven POM - I don't think the 2.0 surefire report works with different versions of
surefire also in the pom.

> Unable to find the mojo when run from continuum
> -----------------------------------------------
>                 Key: CONTINUUM-1595
>                 URL:
>             Project: Continuum
>          Issue Type: Bug
>          Components: Integration - Maven 2
>         Environment: Linux, Maven 2.0.7, Java 1.5.0_10
>            Reporter: Johan Andrén
>         Attachments: buildOutputText.action.txt
> We get the following error when running site generation from continuum:
> Error getting reports from the plugin 'org.apache.maven.plugins:maven-surefire-report-plugin':
Unable to find the mojo 'org.apache.maven.plugins:maven-surefire-report-plugin:2.0:report'
in the plugin 'org.apache.maven.plugins:maven-surefire-report-plugin'
> Component descriptor cannot be found in the component repository: org.apache.maven.plugin.Mojoorg.apache.maven.plugins:maven-surefire-report-plugin:2.0:report.
> I have attached run with -X and -e
> When the same command ("mvn clean site site:deploy") is run from a shell for the user
that continuum runs with the same maven version.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message