continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Guther (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-972) Unable to delete projects
Date Fri, 25 Apr 2008 15:37:46 GMT

    [ http://jira.codehaus.org/browse/CONTINUUM-972?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=132642#action_132642
] 

Andreas Guther commented on CONTINUUM-972:
------------------------------------------

We have a similar problem.  And we have seen that in Continuum beta  versions as well.

We had a process that got hung and we then tried to delete the project.  That might have been
the wrong approach to the hung process.  However, now we are not able to delete the project
from the group.

What we see at the UI is the following:

javax.jdo.JDOUserException: One or more instances could not be deleted NestedThrowables: javax.jdo.JDODataStoreException:
Delete request failed: DELETE FROM PROJECTDEPENDENCY WHERE PROJECTDEPENDENCY_ID=? NestedThrowables:
SQL Exception: DELETE on table 'PROJECTDEPENDENCY' caused a violation of foreign key constraint
'PROJECT_FK2' for key (40580). The statement has been rolled back.

I am going to attach the stack trace as well.



> Unable to delete projects
> -------------------------
>
>                 Key: CONTINUUM-972
>                 URL: http://jira.codehaus.org/browse/CONTINUUM-972
>             Project: Continuum
>          Issue Type: Bug
>          Components: Core system
>    Affects Versions: 1.0.3
>         Environment: Redhat Enterprise 3
>            Reporter: Uri Moszkowicz
>            Assignee: Emmanuel Venisse
>             Fix For: 1.1-alpha-1
>
>         Attachments: stack-trace-cannot-delete-project.txt
>
>
> I am unable to delete project sometimes. I've tried creating a simple project and immediately
deleting it. That seems to work. But when I create a real project, let it run for a few days
and then try to delete it I cannot.
> To reproduce:
> 1. Install continuum
> 2. Create a project
> 3. Let it run for at least one build (success or failure doesn't matter)
> 4. Delete the project by clicking on "X" from main project page. A delete confirmation
page should then appear.
> 5. Click on the "delete" button to confirm. The web browser then begins loading but it
never terminates. The logs show no exceptions. The delete just hangs.
> I've removed all the files from the build-output and working-directory and tried deleting
again. This makes no difference. If you interrupt the delete and click on show projects the
projects page ends up in an inconsistent state (not as many columns, no buttons, an Apache
copyright message).

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message