continuum-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Baptiste MATHUS (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (CONTINUUM-1683) Plexus.sh doesn't run on a Aix JVM
Date Wed, 05 Mar 2008 11:39:28 GMT
Plexus.sh doesn't run on a Aix JVM
----------------------------------

                 Key: CONTINUUM-1683
                 URL: http://jira.codehaus.org/browse/CONTINUUM-1683
             Project: Continuum
          Issue Type: Bug
          Components: Integration - Shell
    Affects Versions: 1.1
         Environment: IBM Unix Aix 5.3.0.0
            Reporter: Baptiste MATHUS
            Priority: Critical
         Attachments: plexus.sh, plexus.sh.diff

I'm upgrading to continuum 1.1. We were using continuum 1.0.3 until now.

As there's no wrapper for this platform, we directly start the plexus.sh script.
Since the 1.1, the "-XX:MaxPermSize" option has been added.

Unfortunalely, it seems like it's an option that's only supported by HotSpot (or at least,
not by the IBM JVM on Aix).
Here the error :
[P520]/cic/soft/continuum-1.1/bin:./plexus.sh.original
Using PLEXUS_HOME:   /cic/soft/continuum-1.1
Using PLEXUS_BASE:   /cic/soft/continuum-1.1
Using PLEXUS_TMPDIR: /cic/soft/continuum-1.1/temp
Using JAVA_HOME:     /cic/soft/java
JVMJ9VM007E Command-line option unrecognised: -XX:MaxPermSize=128m
Could not create JVM.
Usage: java [-options] class [args...]

So I wrote a small patch to activate this option only when java -version contains "HotSpot".

I'm attaching the diff between the plexus.sh included in the 1.1 distribution and the one
I modified + the modified one for convenience. 

There was also a small problem at the beginning on the file :
PLEXUS_OPTS="$PLEXUS_OPTS -Xmx384" without the m. 

On my conf, this displays :
[P520]/cic/soft/continuum-1.1/bin:./plexus.sh
Using PLEXUS_HOME:   /cic/soft/continuum-1.1
Using PLEXUS_BASE:   /cic/soft/continuum-1.1
Using PLEXUS_TMPDIR: /cic/soft/continuum-1.1/temp
Using JAVA_HOME:     /cic/soft/java
JVMJ9GC017E -Xmx too small, must be at least 1 Mbytes
JVMJ9VM015W Initialization error for library j9gc23(2): Failed to initialize
Could not create JVM.

Please feel free to ask any question or do any modification you want on this patch.

Cheers.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message