continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Update installation requirements from Java 5?
Date Tue, 15 Oct 2013 01:53:52 GMT
I fixed the issue since it was easy to do. I think we can reasonably continue Java 5 support
for Continuum 1.4.x, with the caveat that the standalone install comes with Jetty 8, which
requires Java 6.

For working on Continuum 1.5 or above, I'd certainly be happy for anyone to bump the minimum
requirement to either Java 6 or 7, depending on what they need.

On 03/10/2013, at 9:58 AM, Louis Smith <dr.louis.smith@gmail.com> wrote:

> I agree with the removal of 5.. I think we might even want to start
> suggesting 7... 8 is at full feature with GA due in the spring.
> 
> I know I have been facing J7 issues with other products - so I don't see
> any reason to hold back if any of the dependencies have already started to
> move up.
> 
> Louis
> 
> 
> On Wed, Oct 2, 2013 at 7:51 PM, Brent Atkinson <brent.atkinson@gmail.com>wrote:
> 
>> Greetings dev,
>> 
>> The root cause of
>> CONTINUUM-2712<https://jira.codehaus.org/browse/CONTINUUM-2712>,
>> is not clear at the moment, but when responding to it I couldn't help but
>> wonder if we might want to update the installation instructions on the web
>> site to suggest using Java 6 or later.
>> 
>> If it turns out to be caused by a dependency continuum uses that is built
>> with Java 6 or later, I am even more inclined to remove references to using
>> Java 5. It is at end-of-life and will only become more common moving
>> forward.
>> 
>> Brent
>> 
> 
> 
> 
> -- 
> Dr. Louis Smith, ThD
> Chief Technology Officer, Kyra InfoTech
> Museum Director, Veterans Memorial Railroad

--
Brett Porter   @brettporter
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter


Mime
View raw message