continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brent Atkinson <brent.atkin...@gmail.com>
Subject Re: Getting Selenium tests updated
Date Tue, 21 Aug 2012 04:08:04 GMT
So, I think part of my issue was that I wasn't cleaning the webapp-test
project (because clean install from root didn't traverse into that project)
so some of the failures were due to stale databases. The result is only 5
failures:

Failed tests:
testBuildShellProjectWithDistributedBuildsEnabled(org.apache.continuum.web.test.DistributedBuildTest):
Timed out after 120000ms

testProjectGroupAllBuildSuccessWithDistributedBuilds(org.apache.continuum.web.test.DistributedBuildTest):
Timed out after 120000ms

testAddMavenToolWithBuildEnvironment(org.apache.continuum.web.test.InstallationTest):
expected:<Continuum - Installations> but was:<Continuum - Installation>
  setUp(org.apache.continuum.web.test.ReleaseTest): Unable to delete
existing prepared-releases.xml file
  setUp(org.apache.continuum.web.test.ReleaseTest): Unable to delete
existing prepared-releases.xml file

Tests run: 269, Failures: 5, Errors: 0, Skipped: 14

The time outs might be due to the fact that the build still appears to be
trying to execute build.sh (DistributedBuildTest.java:156).

The testAddMavenToolWithBuildEnvironment failure appears to be because of
the characters in my Windows path "C:\Program Files (x86)\Apache Software
Foundation\apache-maven-2.2.1\bin\.."

I can't see why the ReleaseTest.java's setUp() fails, but I think it might
be running up against a path length limitation.

On Mon, Aug 20, 2012 at 10:55 PM, Brett Porter <brett@apache.org> wrote:

> Thanks Brent!
>
> target/failsafe-reports/index.html will list the full errors, and
> target/screenshots will capture a screenshot of each failure.
>
> target/logs contains the actual Continuum logs if you need further info of
> what was going on in the server at the time.
>
> I'm on IRC if you need any immediate help.
>
> - Brett
>
> On 21/08/2012, at 12:45 PM, Brent Atkinson <brent.atkinson@gmail.com>
> wrote:
>
> > Sorry, I mean I did. I svn up'ed and built everything from the root. I'm
> > watching the tests as I write this, but there are still some failures.
> I'm
> > digging into them to find out what's going on.
> >
> > Brent
> >
> > On Mon, Aug 20, 2012 at 10:44 PM, Brent Atkinson
> > <brent.atkinson@gmail.com>wrote:
> >
> >> I will
> >> On Aug 20, 2012 4:05 AM, "Brett Porter" <brett@apache.org> wrote:
> >>
> >>> Make sure you've built Continuum itself, as I did fix some problems in
> >>> the Ant & Shell project addition.
> >>>
> >>> I've set up a Continuum job to confirm the tests also pass on Linux:
> >>>
> http://vmbuild.apache.org/continuum/buildResult.action?buildId=24644&projectId=261
> >>>
> >>> So, looks like we're good here with the exception of Windows - and
> should
> >>> be ready to move forward with the next steps of the release...
> >>>
> >>> - Brett
> >>>
> >>> On 17/08/2012, at 5:58 AM, Brent Atkinson <brent.atkinson@gmail.com>
> >>> wrote:
> >>>
> >>>> I'm still getting errors, but it definitely looks better than before.
> I
> >>>> can't dig into it since I have to run out in the next few minutes, but
> >>> the
> >>>> summary was:
> >>>>
> >>>> Tests run: 331, Failures: 18, Errors: 0, Skipped: 126, Time elapsed:
> >>>> 953.947 sec <<< FAILURE!
> >>>>
> >>>> Failed tests:
> >>>> testAddAntProject(org.apache.continuum.web.test.AntProjectTest):
> >>>> expected:<Continuum - Project Group> but was:<Continuum - Add
Ant
> >>> Project>
> >>>> tearDown(org.apache.continuum.web.test.BuildAgentsTest):
> >>>> 'agent_groupname' is present. expected:<false> but was:<true>
> >>>> tearDown(org.apache.continuum.web.test.BuildAgentsTest):
> >>>> 'agent_groupname' is present. expected:<false> but was:<true>
> >>>>
> >>>>
> >>>
> testAddBuildEnvironment(org.apache.continuum.web.test.BuildEnvironmentTest):
> >>>> expected:<Continuum - Build Environments> but was:<Continuum
- Build
> >>>> Environment>
> >>>>
> >>>>
> >>>
> testBuildShellProjectWithDistributedBuildsEnabled(org.apache.continuum.web.test.DistributedBuildTest):
> >>>> Timed out after 120000ms
> >>>>
> >>>>
> >>>
> testAddInstallationVariableWithBuildEnvironment(org.apache.continuum.web.test.InstallationTest):
> >>>> expected:<Continuum - Installations> but was:<Continuum -
> Installation>
> >>>>
> >>>>
> >>>
> testAddMavenToolWithBuildEnvironment(org.apache.continuum.web.test.InstallationTest):
> >>>> expected:<Continuum - Installations> but was:<Continuum -
> Installation>
> >>>>
> >>>>
> >>>
> testAddInstallationVariableWithoutBuildEnvironment(org.apache.continuum.web.test.InstallationTest):
> >>>> expected:<Continuum - Installations> but was:<Continuum -Installation>
> >>>>
> >>>>
> >>>
> testAddMavenTwoProjectModuleNameWithSameLetter(org.apache.continuum.web.test.MavenTwoProjectTest):
> >>>> expected:<Continuum - Project Group> but was:<Continuum - Add
Maven
> >>> Project>
> >>>>
> >>>>
> >>>
> testBuildMaven2ProjectWithTag(org.apache.continuum.web.test.MavenTwoProjectTest):
> >>>> expected:<Continuum - Project Group> but was:<Continuum - Add
Maven
> >>> Project>
> >>>> testAddProjectGroup2(org.apache.continuum.web.test.ProjectGroupTest):
> >>> The
> >>>> link 'Test Project Group 2 Name' is present. expected:<false>
but
> >>> was:<true>
> >>>>
> >>>
> testProjectGroupMembers(org.apache.continuum.web.test.ProjectGroupTest):
> >>>> 'username1' is present. expected:<false> but was:<true>
> >>>> setUp(org.apache.continuum.web.test.ReleaseTest): Unable to delete
> >>>> existing prepared-releases.xml file
> >>>> setUp(org.apache.continuum.web.test.ReleaseTest): Unable to delete
> >>>> existing prepared-releases.xml file
> >>>> testAddShellProject(org.apache.continuum.web.test.ShellProjectTest):
> >>>> expected:<Continuum - Project Group> but was:<Continuum - Add
Shell
> >>> Project>
> >>>>
> >>>>
> >>>
> testBasicAddDeleteUser(org.apache.continuum.web.test.UserRolesManagementTest):
> >>>> expected:<[Admin] User Edit> but was:<[Admin] User Create>
> >>>>
> >>>>
> >>>
> testEditDuplicatedBuildEnvironmentParallelBuilds(org.apache.continuum.web.test.BuildEnvironmentTest):
> >>>> expected:<Continuum - Build Environments> but was:<Continuum
- Build
> >>>> Environment>
> >>>>
> >>>>
> >>>
> testQueuePageWithProjectCurrentlyBuilding(org.apache.continuum.web.test.QueueTest):
> >>>> expected:<Continuum - Project Group> but was:<Continuum - Add
Maven
> >>> Project>
> >>>>
> >>>> On Thu, Aug 16, 2012 at 3:24 PM, Brent Atkinson <
> >>> brent.atkinson@gmail.com>wrote:
> >>>>
> >>>>> I'm looking at it now. I'm not certain that it was entirely the
shell
> >>>>> tests, but I'll have an idea very soon.
> >>>>>
> >>>>> Brent
> >>>>>
> >>>>>
> >>>>> On Wed, Aug 15, 2012 at 4:53 PM, Brett Porter <brett@apache.org>
> >>> wrote:
> >>>>>
> >>>>>>
> >>>>>> On 09/08/2012, at 5:19 PM, Brett Porter <brett@apache.org>
wrote:
> >>>>>>
> >>>>>>>
> >>>>>>> On 09/08/2012, at 4:16 PM, Brent Atkinson <
> brent.atkinson@gmail.com>
> >>>>>> wrote:
> >>>>>>>
> >>>>>>>> Yeah,
> >>>>>>>>
> >>>>>>>> I think they're cascading as well.
> >>>>>>>
> >>>>>>> Ok, good to see we mostly get the same results!
> >>>>>>
> >>>>>> I get them all passing now. Can you confirm the same result?
> >>>>>>
> >>>>>>>
> >>>>>>>> I also suspect that there is some UNIX-specific issue
because
> under
> >>>>>> Windows the suite is doing something to make Windows prompt
asking
> >>> how to
> >>>>>> open build.sh during the tests. I've attached the output.
> >>>>>>>
> >>>>>>> I guess this is in the shell tests? Maybe we can skip them
if the
> OS
> >>> is
> >>>>>> windows.
> >>>>>>
> >>>>>> Brent, was this just the shell tests?
> >>>>>>
> >>>>>> - Brett
> >>>>>>
> >>>>>> --
> >>>>>> Brett Porter
> >>>>>> brett@apache.org
> >>>>>> http://brettporter.wordpress.com/
> >>>>>> http://au.linkedin.com/in/brettporter
> >>>>>> http://twitter.com/brettporter
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>
> >>>
> >>> --
> >>> Brett Porter
> >>> brett@apache.org
> >>> http://brettporter.wordpress.com/
> >>> http://au.linkedin.com/in/brettporter
> >>> http://twitter.com/brettporter
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
> http://twitter.com/brettporter
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message