continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marica Tan <>
Subject CONTINUUM-2507 Not a Continuum bug
Date Fri, 07 May 2010 00:41:09 GMT

CONTINUUM-2507 is the one where Continuum can't release because of the BOM
at the start of the POM.

I tried building a POM with a BOM at the start from the command line and I'm
still getting this error:  only whitespace content allowed before start tag
and not \uef (position: START_DOCUMENT seen \uef... @1:1)

Doing the release from the command line also produces the same error and I'm
using Maven 2.2.1

I found some similar issues filed in MAVEN like but it was closed as a duplicate of

I don't think the fix for MNG-2254 really fixes this issue. The plexus
XMLPullParser doesn't handle BOM at the start of the text stream for UTF-8.
So I think this should be fixed either in Maven or the Plexus Util itself.

What do others think?

Any comments or suggestions?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message