continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marica Tan <marica....@gmail.com>
Subject Re: Continuum v1.3.4 not using "Build Environment"?
Date Tue, 22 Sep 2009 01:50:44 GMT
Hi Yanke,
Could you turn on the debug and see if it's included?

The environment variables are added in the commandline environment so it
won't show up unless you turn on the debug mode.

You'll see something similar to this:

2009-09-22 09:48:29,952 [pool-1-thread-1] DEBUG
org.apache.continuum.utils.shell.DefaultShellCommandHelper  -
EnvironmentVariables [MAVEN_TERMINATE_CMD=on, MAVEN_OPTS=-Xms512m -Xmx512m,
M2_HOME=/opt/maven-2.0.9]

--
Marica


On Tue, Sep 22, 2009 at 12:00 AM, yanke <yanke@dplanet.ch> wrote:

>
> Hi,
> In Continuum 1.3.4 I have 2 different "Build Environments" each one using
> some Installation variables I defined:
> 1) Default: JDK=1.6, Maven=2.0.9,  envvar java.awt.headless=true
> 2) OLD: JDK=1.5, Maven=2.0.7,  envvar java.awt.headless=true
>
> When I run clean install on continuum using the DEFAULT Build Environment I
> see (with ps -ef | grep mvn) the following process started:
> 2009-09-21 16:19:49,070 [pool-1-thread-14] INFO
> org.apache.continuum.utils.shell.DefaultShellCommandHelper  - Executing:
> /bin/sh -c cd /data01/j2eeapp/tmp/continuum-1.3.4/data/working-directory/47
> && /data/j2eeapp/opt/maven/maven-2.0.9/bin/mvn --batch-mode
> -Dcontinuum.project.lastBuild.state=2
> -Dcontinuum.project.nextBuild.number=7
> -Dcontinuum.project.name=XXXXXXX -Dcontinuum.project.id=47
> -Dcontinuum.project.version=01.00.00.03-SNAPSHOT
> '-Dcontinuum.project.group.name=XXX Common'
> -Dcontinuum.project.lastBuild.number=6
> -Dmaven.repo.local=/data/j2eeapp/home_j2ee/.m2/repository/ clean install
>
> If I start the same Build Definition with OLD Build Environment I see the
> following process:
> 2009-09-21 16:19:49,070 [pool-1-thread-14] INFO
> org.apache.continuum.utils.shell.DefaultShellCommandHelper  - Executing:
> /bin/sh -c cd /data01/j2eeapp/tmp/continuum-1.3.4/data/working-directory/47
> && /data/j2eeapp/opt/maven/maven-2.0.7/bin/mvn --batch-mode
> -Dcontinuum.project.lastBuild.state=2
> -Dcontinuum.project.nextBuild.number=7
> -Dcontinuum.project.name=XXXXXXX -Dcontinuum.project.id=47
> -Dcontinuum.project.version=01.00.00.03-SNAPSHOT
> '-Dcontinuum.project.group.name=XXX Common'
> -Dcontinuum.project.lastBuild.number=6
> -Dmaven.repo.local=/data/j2eeapp/home_j2ee/.m2/repository/ clean install
>
> I would have expected to see also the -Djava.awt.headless=true variable
> passed to these commands.
>
> Why is it not used? what am I doing wrong?
> Do you know where I can find some documentation about setting envvar?
> (continuum site only explains Tool settings)
>
> thanks in advance,
> Yanke
> --
> View this message in context:
> http://www.nabble.com/Continuum-v1.3.4-not-using-%22Build-Environment%22--tp25530385p25530385.html
> Sent from the Continuum - Dev mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message