continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Trouble with Distributed Build
Date Mon, 16 Mar 2009 04:32:07 GMT
On Sun, Mar 15, 2009 at 5:04 PM, Marica Tan <ctan@exist.com> wrote:

> IMO, the problems with CONTINUUM-2068 have nothing to do with this, since
> those were just jsp bugs.

Thanks for fixing that!

> I was able to build from an agent today  using CONTINUUM-1.3.2-SNAPSHOT
> r754796. Minimal configuration in agent's config file -- output and working
> directories and the master url. No installations and build environments on
> either the master and slave too.
>
> Based on your logs, it means no build context was given to the build agent
> from the master. Could you try building again and see if it still happens?

With that build, I tried it repeatedly and got that same result (stack
trace in the log.)

With the latest (r754809) ... nothing happens.  I added the agent,
which shows as enabled.  I added a project, which I see in the log.
Then I click 'Build all projects'.  Complete silence in the logs,
(both master and agent,) and nothing on the screen.  Same for the
other 'build' icons (to the right of the project, on the group summary
screen, from the build def.)

According to Jan's explanation on the issue for build agent groups,
adding an agent and _not_ putting it in a group should make it
available to a project that's using the default build definition (no
build env, so no agent group).

I'll re-build and re-check everything and post my exact steps, if it
works for you I must be doing something different.

-- 
Wendy

Mime
View raw message