continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Versioning the Continuum database
Date Tue, 05 Aug 2008 00:43:16 GMT
Is there currently any way that Continuum could know that it has been
started up with an old/incompatible database?

In my perfect world, Continuum would sense this and at least politely
refuse to start with an informative message.  Preferably it would
offer to convert the data for me.

The experience I had recently upgrading OmniFocus to the new 1.1 Beta
version was, imo, how an upgrade should work.  It asked if I wanted to
convert and warned me that there was no going back, then made a backup
of the existing data and did the conversion.  A similar concept is
described in "Release It!" [1].

Any thoughts on what it would take to make this happen?

[1] http://www.pragprog.com/titles/mnee/release-it

-- 
Wendy

Mime
View raw message