continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Pietrowicz <...@ncsa.uiuc.edu>
Subject Re: Tomcat failure
Date Thu, 14 Dec 2006 14:54:19 GMT
Has anyone had a chance to look at this, to see if there's something  
obviously wrong?   If it looks ok, I'll start looking anywhere else  
you might suggest.  I'm really at a loss at this point.


On Dec 12, 2006, at 4:06 PM, Stephen Pietrowicz wrote:

> That didn't work.   Here is my addition to server.xml:
>
> <Resource name="jdbc/continuum" auth="Container"  
> type="javax.sql.DataSource">
> <ResourceParams name="jdbc/continuum">
>       <parameter>
>         <name>maxWait</name>
>         <value>5000</value>
>       </parameter>
>       <parameter>
>         <name>maxActive</name>
>         <value>4</value>
>       </parameter>
>       <parameter>
>         <name>password</name>
>         <value></value>
>       </parameter>
>       <parameter>
>         <name>url</name>
>         <value>jdbc:derby:target/database/continuum</value>
>       </parameter>
>       <parameter>
>         <name>driverClassName</name>
>         <value>org.apache.derby.jdbc.EmbeddedDriver</value>
>       </parameter>
>       <parameter>
>         <name>maxIdle</name>
>         <value>2</value>
>       </parameter>
>       <parameter>
>         <name>username</name>
>         <value>continuum</value>
>       </parameter>
>     </ResourceParams>
> </Resource>
> <Resource name="jdbc/users" auth="Container"  
> type="javax.sql.DataSource">
>     <ResourceParams name="jdbc/users">
>       <parameter>
>         <name>maxWait</name>
>         <value>5000</value>
>       </parameter>
>       <parameter>
>         <name>maxActive</name>
>         <value>4</value>
>       </parameter>
>       <parameter>
>         <name>password</name>
>         <value></value>
>       </parameter>
>       <parameter>
>         <name>url</name>
>         <value>jdbc:derby:target/database/users</value>
>       </parameter>
>       <parameter>
>         <name>driverClassName</name>
>         <value>org.apache.derby.jdbc.EmbeddedDriver</value>
>       </parameter>
>       <parameter>
>         <name>maxIdle</name>
>         <value>2</value>
>       </parameter>
>       <parameter>
>         <name>username</name>
>         <value>continuum-users</value>
>       </parameter>
>     </ResourceParams>
> </Resource>
>
>
> and here's my continuum.xml:
>
> <?xml version='1.0' encoding='utf-8'?>
> <Context displayName="Continuum Webapp" docBase="/home/srp/tomcat/ 
> apache-tomcat-5.5.20/webapps/continuum-webapp-1.1-SNAPSHOT.war"  
> workDir="/home/srp/temp_work">
> <ResourceLink name="jdbc/continuum" type=  
> "org.apache.derby.jdbc.EmbeddedDriver" global="jdbc/continuum"/>
> <ResourceLink name="jdbc/users" type=  
> "org.apache.derby.jdbc.EmbeddedDriver" global="jdbc/users"/>
> </Context>
>
> On Dec 12, 2006, at 3:25 PM, Rahul Thakur wrote:
>
>>
>> As a workaround - can you try moving the  <Resource .../> config  
>> from continuum.xml to server.xml under global resoures (just like  
>> mentioned on that thread). Pretty sure I have seen similar errors  
>> with JNDI resource look ups in tomcat, but can't remember the  
>> solution off hand.
>>
>> Cheers,
>> Rahul
>>
>>
>> Stephen Pietrowicz wrote:
>>> I hadn't seen that thread.  Thanks for the pointer to it.
>>>
>>> I do get same message that the originator of that thread gets:
>>>
>>>
>>> -------
>>> 2006-12-12 14:20:31,590 [http-8080-Processor23] INFO   
>>> PlexusContainer                - Loading on start [role]:  
>>> [org.apache.maven.continuum.Continuum]
>>> 2006-12-12 14:20:34,287 [http-8080-Processor23] ERROR 1- 
>>> SNAPSHOT]                    - Exception sending context  
>>> initialized event to listener instance of class  
>>> org.codehaus.plexus.xwork.PlexusLifecycleListener
>>> org.jpox.exceptions.ConnectionFactoryNotFoundException:  
>>> Connection Factory "java:comp/env/jdbc/continuum" not found
>>>         at  
>>> org.jpox.AbstractPersistenceManagerFactory.lookupDataSource 
>>> (AbstractPersistenceManagerFactory.java:175)
>>>
>>>
>>>          [ rest of stack trace deleted]
>>> --------
>>>
>>>  but still haven't figured out the solution, even after adding  
>>> the continuum.xml file to the tomcat conf directory.
>>>
>>> I'm not a Tomcat expert, so I think there are several other  
>>> things I need to do, but I can't tell what.
>>>
>>> Here's what I did:
>>>
>>> This morning I downloaded the bin of Tomcat-5.5.20, along with  
>>> the admin tools, and extracted everything.  I added an account  
>>> with "manager and admin" to the tomcat-users.xml, and then I  
>>> started Tomcat with bin/startup.sh
>>>
>>> For continuum, I did this:
>>>
>>> mvn clean install
>>>
>>> Back in Tomcat I went to the manager, and went down to the Deploy  
>>> section of the page and "uploaded" the war file from the  
>>> continuum-webapp directory to Tomcat.
>>>
>>> Under applications on that page, it now shows "/continuum- 
>>> webapp-1.1-SNAPSHOT".
>>>
>>> I click the start link on that line, and it gives me the message:
>>>
>>> "FAIL - Application at context path /continuum-webapp-1.1- 
>>> SNAPSHOT could not be started".
>>>
>>> and got the same error message in catalina.out as listed above.
>>>
>>> The continuum.xml file I have is:
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <Context path="/continuum-webapp-1.1-SNAPSHOT"
>>>          docBase="${catalina.base}/webapps/continuum-webapp-1.1- 
>>> SNAPSHOT">
>>>
>>>     <Resource name="jdbc/users" auth="Container"  
>>> type="javax.sql.DataSource"
>>>               username="sa"
>>>               password=""
>>>               driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
>>>               url="jdbc:derby:target/database/users;create=true"
>>>     />
>>>     <Resource name="jdbc/continuum" auth="Container"  
>>> type="javax.sql.DataSource"
>>>               username="sa"
>>>               password=""
>>>               driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
>>>               url="jdbc:derby:target/database/continuum;create=true"
>>>     />
>>> </Context>
>>>
>>>
>>> I'm missing something here, and I don't know what it is.
>>>
>>>
>>>
>>> On Dec 11, 2006, at 3:04 PM, Rahul Thakur wrote:
>>>
>>>> Hi,
>>>>
>>>> Are you seeing any other startup errors in the Tomcat logs/console?
>>>>
>>>> BTW, have you seen this thread?
>>>> http://www.nabble.com/RE:-Deploy-trunk-on-tomcat-t2625572.html
>>>>
>>>> Cheers,
>>>>
>>>> Rahul
>>>>
>>>>
>>>> Stephen Pietrowicz wrote:
>>>>> Hi,
>>>>>
>>>>> I've checked out the latest version of Continuum from the  
>>>>> source tree, built it and tried to deploy it on Tomcat/5.5.17.
>>>>>
>>>>> I received the message:
>>>>>
>>>>> FAIL - Application at context path /continuum-webapp-1.1- 
>>>>> SNAPSHOT could not be started
>>>>>
>>>>> Is there a workaround for this?   I'm interested in 1.1 because  
>>>>> of the current Jira in 1.0.3 that prevents the "blame" from  
>>>>> being displayed on SVN checkouts.   If there's a work-around  
>>>>> for that in 1.0.3, I'd be able to use that.
>>>>>
>>>>> Steve
>>>>>
>>>
>>>


Mime
View raw message