continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Williams <a...@handyande.co.uk>
Subject Re: [discuss] Writing WebWork actions
Date Mon, 30 Oct 2006 16:15:56 GMT
I personally agree with the one class for CRUD. The reason I have for 
this is that if you use ModelDriven and the Verifiable (Or whatever - I 
forget the exact names)
it saves much duplication of time. Readability and testing I have found 
easier under this approach too.

Also it is worth noting that there are no unused fields with ModelDriven 
- everything is accessed through the one model class.

Just my tuppence worth

A


Jesse McConnell wrote:
> I also bounced this off of a couple other people over the last day or 
> to..
>
> there seems to be a general consensus from folks that I talked to that
> its a good idea to try and group all the CRUD (Create, Read, Update,
> Delete) actions on objects grouped into a single action.
>
> On that note, it would be good to standardize the method names as
> well, perhaps to:
>
> public String add() {}
> public String update() {}
> public String view() {}
> public String remove() {}
>
> Then we would have the decision of the xwork.xml which could have
> actions for each of these methods on the class, like
>
> <action name="addFoo" class="continuum-foo" method="add">
>
> or on the jsp's we could just use the shortcut of <ww:form 
> action="foo!add">
>
> how does this grab folks?   I think this is a valuable step in things
> since it will give us a chance to audit all of the actions, improve
> the -webapp project for contributors...and -webapp is a great place
> for people to start with continuum...and it will also serve as a good
> swift kick towards finishing off the testing work that emmanuel will
> be committing soon.
>
> jesse
>
>


Mime
View raw message