continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barrie Treloar" <baerr...@gmail.com>
Subject Re: [repost] Re: [1.0.3] NoSuchMethodError: org.codehaus.plexus.util.cli.Commandline.setPid during build
Date Thu, 21 Sep 2006 05:18:55 GMT
Oops, attachment too large.

I also notice this in the output:

[DEBUG] Artifact not found - using stub model: Unable to download the
artifact from any repository

  org.codehaus.plexus:plexus-appserver:pom:1.0-alpha-5-SNAPSHOT

Which I think is related to
http://www.nabble.com/forum/ViewPost.jtp?post=4505897&framed=y when
the codehaus box went boom.

Here are the snapshot repos I am checking:
from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache.snapshots (http://cvs.apache.org/repository),
  snapshots (http://snapshots.maven.codehaus.org/maven2)

Am I missing any?

I might try building 1.0-TRUNK.

On 9/21/06, Barrie Treloar <baerrach@gmail.com> wrote:
> On 9/5/06, Barrie Treloar <baerrach@gmail.com> wrote:
> > The list is rather quiet...
> > Am I missing some documentation on the steps to build on a Windows XP machine?
> > Has anyone else successfully built on a Windows machine?
>
> Sorry for a) reposting and b) not responding.
> For some reason I think I have been unsubcribed from continuum-dev. I
> wondered why the list was so quiet.  Checking nabble I can see people
> have responded...
>
> The output from mvn -X clean install is as attached.
>
> Since it has been so long since I tried this I am not sure whether I
> got past the setPid problem.  However that appears to no longer be the
> problem I am getting.
>
> Now it is:
>
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] One or more required plugin parameters are invalid/missing for
> 'plexus:runtime'
>
> [0] inside the definition for plugin: 'plexus-maven-plugin'specify the
> following:
>
> <configuration>
>   ...
>   <runtimeConfigurationProperties>VALUE</runtimeConfigurationProperties>
> </configuration>
>
> -OR-
>
> on the command line, specify: '-DappProperties=VALUE'
>
>
> Which I can see an email at
> http://www.nabble.com/forum/ViewPost.jtp?post=3612509&framed=y
>
> Cheers
>
>
>

Mime
View raw message