continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trygve Laugstøl <tryg...@apache.org>
Subject Re: JPOX errors on startup
Date Sat, 12 Aug 2006 14:31:56 GMT
On Sat, 2006-08-12 at 05:18 -0700, Erik Bengtson wrote:
> I've downloaded continuum 1.3 and collected some errors from the first startup.
> If they are expected, IMO they should not be printed to the logs, unless DEBUG
> is enabled.
> 
> 
> I must say the first startup takes very long. Please let me know where I can
> help.
> 
> 1-----------------------------------------------------
> 
> 
> jvm 1    | 2006-08-12 14:00:44,656 [WrapperSimpleAppMain] INFO  SCHEMA
>                - Initialising Catalog "", Schema "SA" using "SchemaTable" auto-s
> tart option

The Continuum code is not logging this, AFAIK it somewhere between JPOX
and Derby.

> 
> 2-----------------------------------------------------
> 
> org.codehaus.plexus.personality.plexus.lifecycle.phase.StoppingException: Error
> storing the Continuum configuration.

This seems to be because of other JPOX issues that we're having. I
remember Emmanuel or you had some clues on how to fix this earlier which
I'm pretty sure will fix this issue too.

> 
> 
> 3 --------------------------------------------------------------
> jvm 3    | 2006-08-12 14:04:59,468 [WrapperSimpleAppMain] WARN  RDBMS
>                - Column BUILDDEFINITION.LATEST_BUILD_ID should not allow nulls b
> ut does. You can prevent nulls by specifying "allows-null" as "false" for the <f
> ield> in the MetaData

Dunno, Emmanuel?

Another issue I've looked into is the two minute (or 2x 1 minute) delay
when starting up. IIRC you said it was because JPOX was validating the
database, and that seems to be the cause but I haven't been able to stop
JPOX from validating it. I've set the three properties to false, but it
didn't help. I don't have the logs here but I can make a tarball
illustrating the problem later.

--
Trygve



Mime
View raw message