continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-578) Continuum doesn't add new projects using effective POM
Date Fri, 10 Feb 2006 13:27:47 GMT
    [ http://jira.codehaus.org/browse/CONTINUUM-578?page=comments#action_58350 ] 

Emmanuel Venisse commented on CONTINUUM-578:
--------------------------------------------

I think it's fixed by my yesterday's patch. Can you provide a set of sample pom? so i'll can
check it.


> Continuum doesn't add new projects using effective POM
> ------------------------------------------------------
>
>          Key: CONTINUUM-578
>          URL: http://jira.codehaus.org/browse/CONTINUUM-578
>      Project: Continuum
>         Type: Bug

>   Components: Core system
>     Versions: 1.0.2
>     Reporter: Matthew Beermann
>      Fix For: 1.0.3

>
>
> I have a series of projects that inherit <defaultGoal>deploy</defaultGoal>,
but one of the active profiles in the Continuum build environment overrides this to <defaultGoal>site-deploy</defaultGoal>
(confirmed by help:effective-pom).
> However, when I add the project to Continuum, it still ends up having "deploy" as its
goal. This strongly suggests that Continuum isn't applying active profiles to the POM before
reading it. This could be a problem in other contexts as well - what if it was, for example,
a profile that was supplying the SCM connection data?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message