continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-500) windows client to windows server cvsnt connection: wrong cvsroot value?
Date Thu, 08 Dec 2005 14:03:46 GMT
    [ http://jira.codehaus.org/browse/CONTINUUM-500?page=comments#action_53063 ] 

Emmanuel Venisse commented on CONTINUUM-500:
--------------------------------------------

cvsRoot that appears in logs is the cvsRoot that will be store in .cvspass file (not used
by cvsnt).
The standard format of cvsroot is without colon between port and path, but cvsNT add a colon
between them.

pipe are used only as separator in scm url, it's never used in cvsroot.


> windows client to windows server cvsnt connection: wrong cvsroot value?
> -----------------------------------------------------------------------
>
>          Key: CONTINUUM-500
>          URL: http://jira.codehaus.org/browse/CONTINUUM-500
>      Project: Continuum
>         Type: Bug

>     Versions: 1.0.1
>  Environment: Installed on PC running continuum server: 
> Windows XP Prof. 5.1.2600
> cvsnt 2.0.51d
> Both Maven 1.0.2 and Maven 2.0 installed
> Continuum 1.0.1
> j2sdk1.4.2_08
> CVS server: Windows Server 2003 (?)
>     Reporter: Peter Hertogen
>     Assignee: Emmanuel Venisse
>      Fix For: 1.0.2

>
>
> problem in connecting from windows XP client to windows CVS server using cvsnt.
> This is the  entry in registry for cvspass variable:  :pserver:myusername@mycvsserver:2401:D:\dept\P-ITSource
> This was put in the reg by running  C:\Documents and Settings\myusername>cvs -d  :pserver:myusername@mycvsserver:D:\dept\P-ITSource
login
>  Logging in to :pserver:myusername@mycvsserver:2401:D:\dept\P-ITSource
>  CVS password: ********
>  
>  The scm url in my Maven 1.0.2 project.xml is the following:
>  
>   <repository>
>   <connection>
>            scm|cvs|pserver|myusername@mycvsserver|D:\dept\P-ITSource|testMaven
>   </connection>
>   </repository>
>  
>  However, in the continuum.log I see this:
>  
>                                                                                     
                                 ......                   cvsRoot: :pserver:myusername@mycvsserver:2401D:\dept\P-ITSource
>  890622 [Thread-1] DEBUG org.apache.maven.scm.manager.ScmManager  - passFile: C:\Documents
and Settings\myusername\.cvspass
>  
>  I noticed there is no colon (and no pipe either) present anymore in the cvsroot variable
between 2401 and D
>  
>  So I tried manually :
>  
>  C:\Documents and Settings\myusername>cvs -d  :pserver:myusername@mycvsserver:2401D:\dept\P-ITSource
login 
>  Logging in to :pserver:myusername@mycvsserver:2401:\dept\P-ITSource
>  CVS password: ********
>  cvs [login aborted]: \dept\P-ITSource: no such repository
>  
>  Could this be the error, or is it normal that this colon between 2401 and  D is missing
in cvsroot in continuum.log?
> Feedback of Emmanuel on this was : "arrrg, bad cvsnt. It's an other standard that cvsnt
doesn't respect."

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message