continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zach B (JIRA)" <>
Subject [jira] Commented: (CONTINUUM-413) build reported as successful on win xp even when maven 1 build fails
Date Fri, 04 Nov 2005 01:35:06 GMT
    [ ] 

Zach B commented on CONTINUUM-413:

I've tried every conceivable combination of return codes, echo statements, etc.  I even tried
exiting before @endlocal in the maven.bat script to see if env vars were getting erased before
the exit code was returned.  I was not able to get a failed maven build to report as a build
failure in Continuum.  I'm completely confused at this point as to what is either causing
the problem, or what specifically is causing the problem for me.  I can reproduce at will
a non-zero code and echo it as the last command before exiting maven.bat according to windows
conventions (exit /B 1)--but still no reported failure.

> build reported as successful on win xp even when maven 1 build fails
> --------------------------------------------------------------------
>          Key: CONTINUUM-413
>          URL:
>      Project: Continuum
>         Type: Bug
>     Versions: 1.0
>  Environment: Maven 1.0.2
> Java 1.5
> Win XP SP2
> Continuum 1.0
>     Reporter: Zach B
>     Assignee: Emmanuel Venisse
>      Fix For: 1.1

> Continuum always reports a successful build even when Maven reports a build failure.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message