continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-328) Cannot build continuum from scratch
Date Sun, 02 Oct 2005 07:49:09 GMT
    [ http://jira.codehaus.org/browse/CONTINUUM-328?page=comments#action_47618 ] 

Emmanuel Venisse commented on CONTINUUM-328:
--------------------------------------------

jdbc jars come from transitive dependencies, we need to fix poms in repo for use only one
name
jaas come from a transitive dependency but we can exclude it in continuum

> Cannot build continuum from scratch
> -----------------------------------
>
>          Key: CONTINUUM-328
>          URL: http://jira.codehaus.org/browse/CONTINUUM-328
>      Project: Continuum
>         Type: Bug
>  Environment: continuum trunk 2005-10-01 + jdk 1.4.2 + maven 2 built from trunk
>     Reporter: Arnaud Heritier

>
>
> I'm trying to build continuum for the first time (to try to see why the alpha4 and the
last snapshot doesn't start on windows - same problem as emmanuel with the command line length)
and I receive this error :
> [INFO] ----------------------------------------------------------------------------
> [INFO] Building Continuum Plexus Application
> [INFO]    task-segment: [clean:clean, install]
> [INFO] ----------------------------------------------------------------------------
> [INFO] [clean:clean]
> [INFO] ----------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ----------------------------------------------------------------------------
> [INFO] Diagnosis: DEPRECATED: Mapped-prefix lookup of mojos are only supported from direct
invocation. Please use specification of the form groupId:artifactId[:
> version]:goal instead. (Offending mojo: 'plexus:app', invoked via: 'install')
> [INFO] ----------------------------------------------------------------------------
> [INFO] ----------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ----------------------------------------------------------------------------
> FATAL ERROR: Error executing Maven for a project
> Error stacktrace:
> org.apache.maven.reactor.ReactorException: Error executing project within the reactor
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:282)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:237)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:324)
>         at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.lifecycle.LifecycleExecutionException: DEPRECATED: Mapped-prefix
lookup of mojos are only supported from direct invocation. Please u
> se specification of the form groupId:artifactId[:version]:goal instead. (Offending mojo:
'plexus:app', invoked via: 'install')
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoDescriptor(DefaultLifecycleExecutor.java:1154)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindLifecycleForPackaging(DefaultLifecycleExecutor.java:831)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycleMappings(DefaultLifecycleExecutor.java:798)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:475)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:298)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:152)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:217)
>         ... 9 more
> I don't know if it's a problem with m2 or continuum.
> Some others questions :
> - Why do we need to have a jar called jdbc-2.0 and another called jdbc-ext-2.0. It seems
that they are the same one.
> - Why do we need to download the jass 1.0 API which is bundle in jdk 1.4 (pre-requisite
for continuum) ?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message