continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Allison (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (CONTINUUM-321) Maven 2 properties are ignored
Date Tue, 27 Sep 2005 10:33:11 GMT
    [ http://jira.codehaus.org/browse/CONTINUUM-321?page=comments#action_47232 ] 

Bob Allison commented on CONTINUUM-321:
---------------------------------------

I think I found the problem.  As I was digging a little further into how projects got loaded
into Continuum, it looks like all of the projects with packaging=pom were ignored.  Unfortunately,
this meant that the tree structure was also lost.  This is why m2 was unable to resolve the
properties from the parent without doing a download.  When I made temporary changes to the
top-level POM to make it's packaging=jar and remove the modules, I got a single project of
the top level.  After removing the "--non-recursive" option, it looks like it is resolving
the properties correctly.

> Maven 2 properties are ignored
> ------------------------------
>
>          Key: CONTINUUM-321
>          URL: http://jira.codehaus.org/browse/CONTINUUM-321
>      Project: Continuum
>         Type: Bug
>     Versions: 1.0-alpha-4
>  Environment: Running release 1.0-alpha-4 on Linux, using Maven 2.0-beta-1 release
>     Reporter: Bob Allison

>
>
> My Maven 2 project tree consists of a parent directory with a pom.xml and a set of child
projects in subdirectories of the parent directory.  In the parent project, I am using a pair
of properties to define the build version as follows:
> <project>
>   <properties>
>     <revision>3.0</revision>
>     <snapshot>-SNAPSHOT</snapshot>
>   </properties>
> ...
>   <version>${revision}${snapshot}</version>
> ...
> </project>
> I have tried placing the properties in the parent project and in the child project, but
I get the same results.
> When I run the build with m2 from the command line, everything builds, installs, and
deploys correctly.  When the child project is built with Continuum, the output from Maven
looks like:
> jvm 1    | 2005-09-26 13:08:13,244 [Thread-0] WARN  MavenProjectBuilder            -
> jvm 1    |   ***** Using defaults for missing POM qaccess:3rd-party:pom:${revision}${snapshot}
*****

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message