continuum-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim O'Brien (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (CONTINUUM-173) plexus.bat doesn't start Continuum on Windows XP
Date Fri, 27 May 2005 15:24:23 GMT
plexus.bat doesn't start Continuum on Windows XP
------------------------------------------------

         Key: CONTINUUM-173
         URL: http://jira.codehaus.org/browse/CONTINUUM-173
     Project: Continuum
        Type: Bug
  Components: continuum-core  
    Versions: 1.0-alpha-2    
    Reporter: Tim O'Brien
     Fix For: 1.0-alpha-3
 Attachments: plexus.bat

The getting started instruction tell you to start Continuum by running "bin\plexus.bat" on
a Windows machine, but when I tried to run that BAT file all I got was a message "Usage: plexus.bat
<xml>".  The "bin/plexus.sh" works fine from Cygwin, but the plexus.bat file wasn't
passing the configuration argument to Launcher.

If the following variables are added to the end of the :endInit section, the BAT script will
start Continuum successfully:

SET PLEXUS_CONF=%PLEXUS_HOME%\conf
SET CONF=%PLEXUS_CONF%\plexus.xml
SET PLEXUS_CMD_LINE_ARGS=%CONF% %PLEXUS_CMD_LINE_ARGS%

I've attached my plexus.bat to this issue.

Is this a bug, or am I just doing something stupid?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message