community-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Resende <luckbr1...@gmail.com>
Subject Re: Getting this error upon trying to install and configure Hive
Date Thu, 18 Jul 2013 23:41:57 GMT
On Thu, Jul 18, 2013 at 2:48 PM, gerald.park@gtnexus.com <
gerald.park@gtnexus.com> wrote:

> Hi there!
>
> So a little background. I've been trying to setup Hive on a CentOS 6
> machine.
> I followed the instructions of this Youtube video:
> http://www.youtube.com/watch?v=L2lSrHsRpOI
>
> For my case, I'm using Hadoop-1.1.2 and Hive-0.9.0, all the directories
> labeled "mnt" in this video I replaced it with "opt" because that's where
> all of my hadoop and hive packages have been opened up.
>
> As I reached the portion of the video where I was actually supposed to run
> Hive via "./hive" this error popped up:
>
>     "Cannot find hadoop installation: $HADOOP_HOME must be set or hadoop
> must be in the path"
>
> I guess one of the questions I have is, in which directory did I have to
> edit the ".profile" file? because I don't understand why we would have to
> go to the "home" directory for this change. And also if this helps, this is
> what I had put down in the ".profile" file in my /home/hadoop directory
>
>     export HADOOP_HOME=/opt/hadoop/hadoop
>     export HIVE_HOME=/opt/hadoop/hive
>     export PATH=$HADOOP_HOME/bin:$HIVE_HOME/bin
>
> Thank you so much!
>
> Sincerely,
>
> Gerald Park
>

You should direct your question to the Hive project mailing list :
http://hive.apache.org/mailing_lists.html

-- 
Luciano Resende
http://people.apache.org/~lresende
http://twitter.com/lresende1975
http://lresende.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message