community-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject svn commit: r1703015 - in /comdev/projects.apache.org/scripts/import: parsecommittees.py parseprojects.py
Date Mon, 14 Sep 2015 18:02:38 GMT
Author: sebb
Date: Mon Sep 14 18:02:38 2015
New Revision: 1703015

URL: http://svn.apache.org/r1703015
Log:
Check Python version

Modified:
    comdev/projects.apache.org/scripts/import/parsecommittees.py
    comdev/projects.apache.org/scripts/import/parseprojects.py

Modified: comdev/projects.apache.org/scripts/import/parsecommittees.py
URL: http://svn.apache.org/viewvc/comdev/projects.apache.org/scripts/import/parsecommittees.py?rev=1703015&r1=1703014&r2=1703015&view=diff
==============================================================================
--- comdev/projects.apache.org/scripts/import/parsecommittees.py (original)
+++ comdev/projects.apache.org/scripts/import/parsecommittees.py Mon Sep 14 18:02:38 2015
@@ -1,6 +1,8 @@
 import re
 import json
 import sys
+if sys.hexversion < 0x03000000:
+    raise ImportError("This script requires Python 3")
 import io
 import os
 import urllib.request

Modified: comdev/projects.apache.org/scripts/import/parseprojects.py
URL: http://svn.apache.org/viewvc/comdev/projects.apache.org/scripts/import/parseprojects.py?rev=1703015&r1=1703014&r2=1703015&view=diff
==============================================================================
--- comdev/projects.apache.org/scripts/import/parseprojects.py (original)
+++ comdev/projects.apache.org/scripts/import/parseprojects.py Mon Sep 14 18:02:38 2015
@@ -1,3 +1,6 @@
+import sys
+if sys.hexversion < 0x03000000:
+    raise ImportError("This script requires Python 3")
 from xml.dom import minidom
 import xml.etree.ElementTree as ET
 import re, urllib.request



Mime
View raw message