commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject CVE-2021-35517: Apache Commons Compress 1.1 to 1.20 denial of service vulnerability
Date Tue, 13 Jul 2021 04:01:23 GMT

When reading a specially crafted TAR archive, Compress can be made to allocate large amounts
of memory that finally leads to an out of memory error even for very small inputs. This could
be used to mount a denial of service attack against services that use Compress' tar package.


Commons Compress users should upgrade to 1.21 or later.


This issue was discovered by OSS Fuzz.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message